Bug 331101 - Sound card is not detected
Sound card is not detected
Product: Fedora
Classification: Fedora
Component: alsa-lib (Show other bugs)
All Linux
low Severity medium
: ---
: ---
Assigned To: Martin Stransky
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2007-10-13 21:37 EDT by Graham Freeman
Modified: 2008-04-24 19:34 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-04-24 19:34:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Log file generated during test. (183 bytes, text/plain)
2007-10-13 21:37 EDT, Graham Freeman
no flags Details
Other log file created during testing (45.05 KB, text/plain)
2007-10-13 21:39 EDT, Graham Freeman
no flags Details
scrun (3.10 KB, text/plain)
2008-01-25 10:16 EST, Steve Lab
no flags Details

  None (edit)
Description Graham Freeman 2007-10-13 21:37:55 EDT
Description of problem:
When I login, the sound system is not working.  When I run Administration >
Soundcard detection, it reports
Vendor: Ensoniq
Model: ES1371 [AudioPCI-97]
Module: snd-ens1371

with device settings

However when I click to play the Sound Test, is almost immediately asks did I
hear the sound, which I did not.

I arrived at this state after running the command
yum upgrade alsa-lib alsa-utils  kdemultimedia system-config-soundcard

Prior to that, sound was working when logged in as root, but not as an ordinary
user.  When an ordinary user logged in, there was a popup panel immediately with
the message:
Sound server informational message:
Error while initializing the sound driver:
device /dev/dsp can't be opened (Permission denied)
The sound server will continue, using the null output device.

At that time, the device /dev/dsp had these properties:
$ ls -l /dev/dsp
crw-------+ 1 gfreeman root 14, 3 2007-10-13 06:54 /dev/dsp
$ getfacl /dev/dsp
getfacl: Removing leading '/' from absolute path names
# file: dev/dsp
# owner: gfreeman
# group: root
user:gdm:rw-                    #effective:---
user:gfreeman:rw-               #effective:---

I tried chmod 660 /dev/dsp
but it did not improve the situation, which is why I tried upgrading the software.

Version-Release number of selected component (if applicable):

How reproducible:
Every time.  Sound is not working under Linux.  It is working fine under MS XP.

Steps to Reproduce:
1. Login as root
2. Administration > Soundcard detection
3. Click on Test Sound
Actual results:
Popup asking me whether I heard a sound, which I did not.  Then an Error dialog
asking me to submit a report to RedHat

Expected results:
I expected to hear the test sound, which I used to hear as root.

Additional info:
Comment 1 Graham Freeman 2007-10-13 21:37:55 EDT
Created attachment 226571 [details]
Log file generated during test.
Comment 2 Graham Freeman 2007-10-13 21:39:15 EDT
Created attachment 226581 [details]
Other log file created during testing
Comment 3 Graham Freeman 2007-10-13 21:45:24 EDT
The versions of ALSA are as follows:

ALSA Driver version:   Driver Version 1.0.14rc3
ALSA Lib package(s):   alsa-lib-1.0.14-3.fc7
ALSA Utils package(s): alsa-utils-1.0.14-2.fc7
Comment 4 Steve Lab 2008-01-25 10:16:15 EST
Created attachment 292946 [details]

Comment 5 Martin Stransky 2008-02-25 10:33:22 EST
The logs look sane. Please try to update to F8 and check again. There's a huge
sound-system update there.
Comment 6 John Poelstra 2008-04-24 19:34:42 EDT
The information we've requested above is required in order
to review this problem report further and diagnose/fix the
issue if it is still present.  Since there have not been any
updates to the report since thirty (30) days or more since we
requested additional information, we're assuming the problem
is either no longer present in the current Fedora release, or
that there is no longer any interest in tracking the problem.

Setting status to "INSUFFICIENT_DATA".  If you still
experience this problem after updating to our latest Fedora
release and can provide the information previously requested, 
please feel free to reopen the bug report.

Thank you in advance.

Note You need to log in before you can comment on or make changes to this bug.