Bug 33111 - up2date displays incorrect transfer times when retrieving packages
Summary: up2date displays incorrect transfer times when retrieving packages
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: up2date   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: Preston Brown
QA Contact: Jay Turner
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-03-25 07:34 UTC by kev
Modified: 2015-01-07 23:44 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-25 07:34:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description kev 2001-03-25 07:34:03 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.4.0 i686; en-US; 0.8) Gecko/20010215


When retrieving packages, the Red Hat Update Agent (up2date) will display
the time elapsed and the time expired.  The time appears to be displayed as
MM:SS:SS.  I.e, the seconds field is repeated twice.  So, e.g, I see
00:33:33 when there are approximately 33 seconds left,
and 00:32:32 when there are 32 seconds left.  Also, I've seen this middle
field with values larger than 60, when this happens, it appears that the
middle field modulo 60 is being placed in the rightmost field.  (I suspect
that the display is intended to read HH:MM:SS and
the middle field is not being computed properly.)

Reproducible: Always
Steps to Reproduce:
1.Run up2date on a machine connected to the internet with a relatively slow
connection.  (I'm using a 2 channel ISDN connection.)
2.Start retrieval of a fairly large package.
3.Watch time elapsed / time remaining displays.  Observe bug.
	

Actual Results:  See description.

Expected Results:  I would expect the "Package transfer time" and
"remaining" displays to show correct values.

Comment 1 Preston Brown 2001-03-26 22:10:32 UTC
fixed weeks ago in rawhide version of up2date.



Note You need to log in before you can comment on or make changes to this bug.