Bug 331151 - ath5k does not work with MacBook Pro Atheros chips
ath5k does not work with MacBook Pro Atheros chips
Status: CLOSED DUPLICATE of bug 254192
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
All Linux
low Severity urgent
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-13 23:59 EDT by Jussi Eloranta
Modified: 2008-01-24 15:04 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-24 15:04:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jussi Eloranta 2007-10-13 23:59:49 EDT
Description of problem: The new Atheros driver (ath5k) recognizes the wireless
chip in MacBook Pro (intel) but it does not work. For example, iwlist ath0 scan
always returns empty list. On the other hand, the proprietary HAL (madwifi)
works just fine.

lspci -v:

03:00.0 Ethernet controller: Atheros Communications, Inc. AR5006EG 802.11 b/g Wi
reless PCI Express Adapter (rev 01)
        Subsystem: Apple Computer Inc. Unknown device 0086
        Flags: bus master, fast devsel, latency 0, IRQ 17
        Memory at 90100000 (64-bit, non-prefetchable) [size=64K]
        Capabilities: [40] Power Management version 2
        Capabilities: [50] Message Signalled Interrupts: Mask- 64bit- Queue=0/0 
Enable-
        Capabilities: [60] Express Legacy Endpoint IRQ 0
        Capabilities: [90] MSI-X: Enable- Mask- TabSize=1
        Capabilities: [100] Advanced Error Reporting
        Capabilities: [140] Virtual Channel

Note that madwifi (see below) claims that this is not AR5006EG?

dmesg after booting and loading ath5k:

ath_pci 0000:03:00.0: AR5212 chip found: mac 10.10 phy 6.1
ACPI: PCI Interrupt 0000:0c:03.0[A] -> GSI 19 (level, low) -> IRQ 20
net ath0: device_rename: sysfs_create_symlink failed (-17)
udev: renamed network interface wlan0 to ath0

dmesg after rmmodding ath5k and modprobing ath_pci (madwifi with prop. HAL):

ath_hal: module license 'Proprietary' taints kernel.
ath_hal: 0.9.30.13 (AR5210, AR5211, AR5212, AR5416, RF5111, RF5112, RF2413, RF54
13, RF2133)
wlan: 0.8.4.2 (svn r2726)
ath_pci: 0.9.4.5 (svn r2726)
ACPI: PCI Interrupt 0000:03:00.0[A] -> GSI 17 (level, low) -> IRQ 17
PCI: Setting latency timer of device 0000:03:00.0 to 64
ath_pci: switching rfkill capability off
ath_rate_sample: 1.2 (svn r2726)
ath_pci: switching per-packet transmit power control off
wifi0: 11a rates: 6Mbps 9Mbps 12Mbps 18Mbps 24Mbps 36Mbps 48Mbps 54Mbps
wifi0: 11b rates: 1Mbps 2Mbps 5.5Mbps 11Mbps
wifi0: 11g rates: 1Mbps 2Mbps 5.5Mbps 11Mbps 6Mbps 9Mbps 12Mbps 18Mbps 24Mbps 36
Mbps 48Mbps 54Mbps
wifi0: turboG rates: 6Mbps 12Mbps 18Mbps 24Mbps 36Mbps 48Mbps 54Mbps
wifi0: H/W encryption support: WEP AES AES_CCM TKIP
wifi0: mac 10.3 phy 6.1 radio 10.2
wifi0: Use hw queue 1 for WME_AC_BE traffic
wifi0: Use hw queue 0 for WME_AC_BK traffic
wifi0: Use hw queue 2 for WME_AC_VI traffic
wifi0: Use hw queue 3 for WME_AC_VO traffic
wifi0: Use hw queue 8 for CAB traffic
wifi0: Use hw queue 9 for beacons
wifi0: Atheros 5424/2424: mem=0x90100000, irq=17


Kernel version:

kernel-headers-2.6.23-6.fc8
kernel-devel-2.6.23-6.fc8
kernel-2.6.23-6.fc8
Comment 1 John W. Linville 2007-10-16 16:06:35 EDT
There are some ath5k updates in the kernels here:

   http://koji.fedoraproject.org/koji/buildinfo?buildID=21169

YMMV, I get an (apparently) different oops now...

Do these kernels make a difference for you?
Comment 2 Jussi Eloranta 2007-10-17 02:20:17 EDT
No difference. The card is found but can't see anything (e.g. iwlist ath0 scan
fails to find anything)
Comment 3 John W. Linville 2007-10-19 17:52:03 EDT
FYI, info on how to help the ath5k reverse engineering team:

   http://marc.info/?l=linux-wireless&m=119282415503974&w=2
Comment 4 John W. Linville 2007-11-29 09:56:10 EST
Lots of ath5k updates in kernel-2.6.23.8-63.fc8...does that work any better 
for you?
Comment 5 Jussi Eloranta 2007-11-29 20:49:18 EST
Not really. This is what I see in dmesg:

ath5k_hw_nic_wakeup: failed to resume the MAC Chip
ACPI: PCI interrupt for device 0000:03:00.0 disabled
ath5k_pci: probe of 0000:03:00.0 failed with error -5

and I don't see the device at all (I used to see it to some extent before).
Comment 6 Christopher Brown 2008-01-23 18:33:02 EST
Hello,

I'm reviewing this bug as part of the kernel bug triage project, an attempt to
isolate current bugs in the Fedora kernel.

http://fedoraproject.org/wiki/KernelBugTriage

I am CC'ing myself to this bug and will try and assist you in resolving it if I can.

There hasn't been much activity on this bug for a while. Could you tell me if
you are still having problems with the latest kernel?

If the problem no longer exists then please close this bug or I'll do so in a
few days if there is no additional information lodged.
Comment 7 Jussi Eloranta 2008-01-24 14:22:16 EST
Yes, the problem still persists. I believe that the ath5k kernel driver is not
quite ready yet and that's why there the driver does not work on mac book pros.
Comment 8 John W. Linville 2008-01-24 15:04:17 EST

*** This bug has been marked as a duplicate of 254192 ***

Note You need to log in before you can comment on or make changes to this bug.