Bug 331271 - dvgrab gets SEGV during exit cleanup
dvgrab gets SEGV during exit cleanup
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: dvgrab (Show other bugs)
8
i686 Linux
low Severity low
: ---
: ---
Assigned To: Jarod Wilson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-14 06:38 EDT by Pat Kane
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-23 16:25:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pat Kane 2007-10-14 06:38:02 EDT
Description of problem:
The dvgrab program always reports a segmentation fault
when it completes.  Here is a stack trace from gdb:
  (gdb) run -d 1
  Starting program: /usr/src/redhat/BUILD/dvgrab-3.0/dvgrab -d 1
   ... 
  Found AV/C device with GUID 0x002011010101c205
  [New Thread -1315226736 (LWP 4828)]
  [New Thread -1208543536 (LWP 4825)]
  [New Thread -1326355568 (LWP 4829)]
  ""     0.00 MB 0 frames
  Capture Stopped
  [Thread -1326355568 (LWP 4829) exited]
 
  Program received signal SIGSEGV, Segmentation fault.
  [Switching to Thread -1208543536 (LWP 4825)]
  0x003e2bec in free () from /lib/libc.so.6
  (gdb) where
  #0  0x003e2bec in free () from /lib/libc.so.6
  #1  0x005351b0 in iec61883_dv_fb_close () from /usr/lib/libiec61883.so.0
  #2  0x08069e7e in iec61883Reader::StopReceive (this=0xb7e59008)
      at ieee1394io.cc:475
  #3  0x0806a8e2 in iec61883Reader::StopThread (this=0xb7e59008)
      at ieee1394io.cc:353
  #4  0x08053ec1 in DVgrab::cleanup (this=0xbfeca1d4) at dvgrab.cc:1185
  #5  0x080567aa in ~DVgrab (this=0xbfeca1d4) at dvgrab.cc:151
  #6  0x0806cb45 in main (argc=Cannot access memory at address 0x0
      ) at main.cc:134
 

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. run the dvgrab for 1 second with  "dvgrab -d 1"
2. ???
3. profit!
  
Actual results:


Expected results:

Additional info:  might be same problem as BUG 328011
Comment 1 Jarod Wilson 2007-10-22 10:02:49 EDT
Please let me know if you can still reproduce this with libraw1394-1.3.0-2.fc8,
which carries the fix for bug 328011, which does seem like it might take care of
this as well.

Packages can be fetched straight out of koji if they aren't in the
development/f8 repo just yet.

http://koji.fedoraproject.org/packages/libraw1394/1.3.0/2.fc8/
Comment 2 Jarod Wilson 2007-10-22 13:42:36 EDT
Never mind, I've reproduced it with dvgrab-3.0-1.fc8 and libraw1394-1.3.0-2.fc8,
problem still exists.
Comment 3 Jarod Wilson 2007-10-22 17:44:56 EDT
...and now I've got a fix for dvgrab. I don't quite fully understand why a few
things are going on in this code[*], need to talk to upstream, but I'm going to
push this update ASAP since it fixes the segfault.


[*] like StopReceive() calling iec61883_dv_fb_close() instead of
iec61883_dv_fb_stop(), since Close() calls iec61883_dv_fb_close() as well, and
making that change makes things play nice w/juju...
Comment 4 Pat Kane 2007-10-23 07:27:14 EDT
The version at 
   http://koji.fedoraproject.org/packages/dvgrab/3.0/2.fc8/
has fixed the problem.  Thank you for fixing this annoyance.

Pat
----
P.S. Another annoyance I have with my DV equipment is that sometimes
     my F8T3 laptop can not find that Canopus converter box. For
     example late last night I tried to test this bug fix but dvgrab
     could not "see" the Firewire converter box, I rebooted to a few
     different recent kernels but had no better luck -- I turned 
     everything off and went to bed.  This morning I booted to my
     default system (2.6.23-1.fc8) and dvgrab worked okay.  

     I notice that when it does work I get a kernel INFO msg about
     a possible recursive lock from firewire_core. (bug 323411)

     


Comment 5 Jarod Wilson 2007-10-23 16:25:15 EDT
I posted the patch to the kino-dev mailing list last night, will see what folks
have to see there. In the mean time, this patched dvgrab is now slated for
inclusion in Fedora 8, and I'm going to close the bug.
Comment 6 Fedora Update System 2007-11-09 18:53:07 EST
dvgrab-3.0-2.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update dvgrab'

Note You need to log in before you can comment on or make changes to this bug.