Bug 33131 - upgrade from 7.0 to qa0322 fails
Summary: upgrade from 7.0 to qa0322 fails
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
high
high
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-03-25 20:22 UTC by Chris Ricker
Modified: 2005-10-31 22:00 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-26 19:58:51 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Chris Ricker 2001-03-25 20:22:54 UTC
I'm trying to upgrade a machine from a 7.0 custom install (mostly stock RH,
does have more recent openssh, modutils, procmail, and postfix rpms
installed, as well as a 2.4 SMP kernel not from rpm) to qa0322.  Using
either NFS install or local CD install, it dies at the "finding packages to
upgrade" step.  This occurs whether or not I select the "customize
packages" option.  The only error message I get (and it's the same from all
four scenarios) is

python: header.c:511: headerLoad: Assertion `rdlen == dl` failed


Let me know what other information would be useful (list of installed
RPMs?), and if there's any way to get more debugging output than that....

Comment 1 Chris Ricker 2001-03-26 01:07:27 UTC
This appears to be due to a subtly corrupted rpm database on the 7.0 box.  rpm
--rebuilddb didn't fix the problem, but doing an rpm -Va showed that gcc had
gotten part of the postfix log overwriting its description.  Removing and
reinstalling gcc cleared the corruption from the rpm db, and then the upgrade
worked.

You can probably go ahead and close this bug.  More robust handling of corrupt
rpm dbs and / or a more informative error than "python: header.c:511:
headerLoad: Assertion `rdlen == dl` failed" would be nice, though.

Also, failed upgrades due to corrupt db leave lots of droppings behind.  I have
a lot of /var/lib/anaconda-rebuilddb* directories full of rpm db dumps....

Comment 2 Michael Fulbright 2001-03-26 17:22:50 UTC
Jeff any idea what is going on here, and if its been fixed?

Comment 3 Jeff Johnson 2001-03-26 19:58:46 UTC
Nope, there's no way to tell how or when the gcc package was installed before
the
the upgrade was attempted.


Note You need to log in before you can comment on or make changes to this bug.