Bug 331321 - Ugly X lines
Ugly X lines
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
8
i686 Linux
low Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-14 08:30 EDT by Pat Kane
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-15 10:31:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Little Xlib test program (1.32 KB, text/x-csrc)
2007-10-14 08:30 EDT, Pat Kane
no flags Details

  None (edit)
Description Pat Kane 2007-10-14 08:30:50 EDT
Description of problem: X wide lines look ugly.


Version-Release number of selected component (if applicable):


How reproducible: run attached "xlines" test program


Steps to Reproduce:
1. run xlines
2. gaze at screen
3. look at right hand side and try not to puke.
  
Actual results:  barf


Expected results: truth and beauty


Additional info:  zero width lines look okay
Driver info:
(II) I810: Driver for Intel Integrated Graphics Chipsets: i810, i810-dc100,
        i810e, i815, i830M, 845G, 852GM/855GM, 865G, 915G, E7221 (i915),
        915GM, 945G, 945GM, 965G, 965G, 965Q, 946GZ
Comment 1 Pat Kane 2007-10-14 08:30:50 EDT
Created attachment 226611 [details]
Little Xlib test program
Comment 2 Matěj Cepl 2007-10-15 10:31:19 EDT
a) it would be awfully nice, if you would attach some comments on how to compile
your program (aside from the fact, that the code was buggy and was missing some
#includes),
b) reading today's message on xorg list
(http://permalink.gmane.org/gmane.comp.freedesktop.xorg/22496) by Keith Packard,
I feel that this is something we won't fix here.

Closing as WONTFIX.
Comment 3 Pat Kane 2007-10-15 10:54:11 EDT
  > a) 
The top of the test program looks like this:
  
  #include <math.h>
  #include <X11/Xlib.h>
  /*
   * Draw 0 and 1 width lines
   * 
   * build with:  gcc xlines.c -lX11 -o xlines -lm 
   *
   * Pat Kane  2007
   */
what did I forget to include?  Does that gcc line not work for you?

 > b)
Yes, I agree that the "bug" can not be fixed without violating the
broken X spec.  But gosh, someone went to a lot of effort to make
those ugly wide X lines.

Sorry for the noise.
Comment 4 Matěj Cepl 2007-10-15 11:01:40 EDT
a)

#include <stdio.h>
#include <stdlib.h>

plus adding the gcc line
(gcc -o xlines -lX11 -lm xlines.c) even to the comments would be nice -- I have
a lot of bugs to see every day.

b) I understand your pain, but if you want to have this fixed, then probably the
way to do it is to file this bug into http://bugs.freedesktop.org -- we have
enough bugs to make us busy even without fixing specs.

Note You need to log in before you can comment on or make changes to this bug.