Bug 33133 - kickstarting: nfs mount timeout
Summary: kickstarting: nfs mount timeout
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-03-25 21:12 UTC by Andreas J. Bathe
Modified: 2007-04-18 16:32 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-25 21:25:25 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Andreas J. Bathe 2001-03-25 21:12:52 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.2.17-14 i686)


when kickstarting and mounting another directory via nfs during the %post
we get the following error output (see vc4):
<5>portmap: server localhost not responding, timed out
<5>portmap: server localhost not responding, timed out
<4>lockd_up: makesock failed, error=-5
<5>portmap: server localhost not responding, timed out
<4>lockd_down: no lockd running.

Although these messages on VC4, the directory was mounted, but there is a
really long timeout delaying the kickstart process.

You can replicate the mount step on VC2 (but without the lockd warnings)
before you reboot.

Guinness and Zoot did the job without any probs, I did not try Fisher...

Take care
Andreas


Reproducible: Always
Steps to Reproduce:
1. kickstart until installation is completem, but don't reboot
2. mount from an nfs server a directory (server is rh 6.2)
3. or try mounting a directory during the post section

Comment 1 Andreas J. Bathe 2001-03-25 21:25:21 UTC
problem goes (no timeout) when mounting with -o nolock



Comment 2 Brock Organ 2001-03-26 14:50:15 UTC
due to differences between 2.2 and 2.4 kernels, the -nolock is now required to
successfully mount an exported share on a 2.4 system without the portmapper
running ... this is documented in the release notes ... :)

HTH,

Brock


Note You need to log in before you can comment on or make changes to this bug.