Bug 331441 - Please consider upgrading Dovecot to 1.0rc23 at least
Please consider upgrading Dovecot to 1.0rc23 at least
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: dovecot (Show other bugs)
5.0
All Linux
low Severity low
: ---
: ---
Assigned To: Tomas Janousek
https://bugzilla.redhat.com/show_bug....
:
Depends On: 380401
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-14 16:02 EDT by Olivier Castan
Modified: 2008-05-21 10:20 EDT (History)
1 user (show)

See Also:
Fixed In Version: RHSA-2008-0297
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 10:20:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Olivier Castan 2007-10-14 16:02:00 EDT
dovecot-1.0-1.2.rc15.el5

There's an interoperability bug between dovecot and nss_ldap when doing user
lookups. It has been reported for Fedora :
Bugzilla Bug 154314: nss_ldap randomly replying with wrong user's data
https://bugzilla.redhat.com/show_bug.cgi?id=154314

This prevent building secure configurations (multiple UIDs) with authorizations
centralized in LDAP

A workaround has been implemented in Dovecot since 1.0rc23 :
http://wiki.dovecot.org/AuthDatabase/Passwd#head-322ce91bf76fde299341f7faa4769485027791ba
Comment 1 Tomas Janousek 2007-10-14 16:30:01 EDT
The bug in nss_ldap is hopefully getting fixed in EL5.2, but yes, upgrading
dovecot would be good as well :).
Comment 2 RHEL Product and Program Management 2007-10-31 14:24:45 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 5 Matt Soccio 2007-12-03 09:25:20 EST
The convert plugin included in 1.0-1.2.rc15 is severely broken.  This has been
fixed in 1.0rc23 and above.  I am facing having to convert 2k+ users from mbox
to Maildir and this plugin would save many hours of admin time and would allow
us to convert with zero downtime for users.  Please include the rc23 in the beta
channel now, and in the maint update.
Comment 8 errata-xmlrpc 2008-05-21 10:20:20 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHSA-2008-0297.html

Note You need to log in before you can comment on or make changes to this bug.