Bug 331581 - yum prints urlencoded error messages for ftp
yum prints urlencoded error messages for ftp
Status: CLOSED DUPLICATE of bug 171664
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-14 20:21 EDT by Doncho N. Gunchev
Modified: 2014-01-21 17:59 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-16 14:05:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Doncho N. Gunchev 2007-10-14 20:21:25 EDT
Description of problem:
Yum prints urlencoded error messages for ftp in bulgarian locale.

Version-Release number of selected component (if applicable):
yum-3.2.7-1.fc8

How reproducible:
sometimes

Steps to Reproduce:
1. yum -y update
  
Actual results:
Trying other mirror.
ftp://ftp.pbone.net/pub/fedora/linux/development/i386/os/Packages/kernel-devel-2.6.23-6.fc8.i686.rpm: 
[Errno 4] IOError: [Errno ftp error] 
(111, '\xd0\x9e\xd1\x82\xd0\xba\xd0\xb0\xd0\xb7\xd0\xb0\xd0\xbd\xd0\xbe 
\xd1\x81\xd0\xb2\xd1\x8a\xd1\x80\xd0\xb7\xd0\xb2\xd0\xb0\xd0\xbd\xd0\xb5')
Trying other mirror.

Expected results:
Trying other mirror.
ftp://ftp.pbone.net/pub/fedora/linux/development/i386/os/Packages/kernel-devel-2.6.23-6.fc8.i686.rpm: 
[Errno 4] IOError: [Errno ftp error] (111, 'Отказано свързване')
Trying other mirror.


Additional info:
php -r 'echo 
urldecode("\xd0\x9e\xd1\x82\xd0\xba\xd0\xb0\xd0\xb7\xd0\xb0\xd0\xbd\xd0\xbe 
\xd1\x81\xd0\xb2\xd1\x8a\xd1\x80\xd0\xb7\xd0\xb2\xd0\xb0\xd0\xbd\xd0\xb5\n");'
reveals the real message: 'Отказано свързване' ('Connection refused' in 
Bulgarian).
I have no idea where this translation comes from, yum has no Bulgarian 
translation AFAIK.
Comment 1 Jeremy Katz 2007-10-16 14:05:44 EDT

*** This bug has been marked as a duplicate of 171664 ***

Note You need to log in before you can comment on or make changes to this bug.