Bug 33254 - RPM downloads stall
RPM downloads stall
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-26 10:52 EST by Richard Hebert
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-27 10:26:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard Hebert 2001-03-26 10:52:19 EST
RH7  Two computers  Celeron and Cyrix
Same os on both ,same setup.Fresh install.
56 k PCI modem,lan install.
No upgrades done ,fresh out the box.
On those two computers is it impossible to download any rpm 
of size larger than 1.135MB. This in any program available when we install.
gFTP,Netscape ,NcFtp all stall after opening ~ 30k or less.
I tried passive ftp with the same results.Stalls.
Now smaller rpm's will download.(up to 1135k they work )
I have tried this at every possible hour.
I have tried it on close to 30 sites,http and ftp.
For example  www.ximian.com
On the packages download page,from any of the mirror sites ( i tried them all )
all files smaller than 1135 k do download.
Any files larger in size ,start downloading ,stall and hang until timeout,or indefinitely.
Same thing on all web sites.Including Opera,Linuxapps,IceWalkers,Freshmeat
There is one case where a large RPM will download and it's through the update
agent.They will download and install properly.

I have reloaded RH7  six  times to try to fix this.
I have also tried all the web sites i could before thinking to even submit this report.
and this at all possible hours.
I have two ISP's and i checked this with both connections with the same result.

If you need any more details ill be happy to help.

Sincere thanks.

Richard Hebert
hebertrich@operamail.com
hebertrich@yahoo.com
Comment 1 Jeff Johnson 2001-03-26 10:56:34 EST
ARe you using rpm itself as a FTP/HTTP client to download? Or are you using
some other client like ncftp, wget, etc to download?
Comment 2 Richard Hebert 2001-03-26 11:12:51 EST
Good Morning

I am using the ncftp ,gFTP and Netscape clients to download .
they all fail.I tried Opera this morning too with the same result.
All other file types do download ,whatever sizes they have.
I have no idea what's going on.

Richard 







Comment 3 Jeff Johnson 2001-03-26 11:18:23 EST
You can try running tcpdump as root while downloading. Be prepared for a *lot*
of output, but look carefully at what's happening when the transfer stalls. That
should
provide some hints as to what is happening when the stall occurs.
Comment 4 Richard Hebert 2001-03-27 10:25:59 EST
After several runs, here is the analysis.
There is normal transaction between the client ,the isp and the server.Download
starts.
The firewall on this machine (Firestarter 0.6.1) then blocks the port on which
the isp is trying to  download the file  to me.(Port 1000 and up , trin00/1524
etc)
The server tries another port and another (several hundreds) always rejected by
the firewall.
Now  why only on RPM ? I have no idea.but it's not a problem with RPM's but with
the firewall
i have. (A firewall was the first thing i installed after getting the machines
on the net ,old habit
that i picked up working with W...just cant pronounce it anymore...) 
I have written directly to Firestarter for ways to fix this on my side.
They have unfortunately no documentation available online about setting up
rules.
This shows i have to get cracking in these books about RedHat and study in a
wholly 
new feild for me :programming. (ipchains is the first target i guess  )
Thanks for the help.
Sorry but this was no rpm bug but a  firewall configuration error.

Have a great day.

Sincerely yours
Richard Hebert

Note You need to log in before you can comment on or make changes to this bug.