Bug 33259 - No Service Transfer when Inside NIC fails
No Service Transfer when Inside NIC fails
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: heartbeat (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Copeland
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-26 11:30 EST by Ralph Sprainer
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-14 15:14:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Red Hat Bugzilla 2001-03-26 11:30:31 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.0; Windows 98; DigExt)


I am using Red Hat 6.2 upgraded to HA 1.0.  When the inside network NIC is 
physically unplugged on the primary LVS router, the virtual services are 
not transfered to the backup LVS router.  All that happens is that the 
Real Servers are lost by the LVS Primary Router and web services go away.  
However, all is fine when the public (outside NIC) is unplugged.

Reproducible: Always
Steps to Reproduce:
1.Unplug the Inside NIC from the hub on the Primary LVS router.
2.
3.
	

Actual Results:  Lost the Real Servers in the Primary LVS routing table as 
viewed on piranha.  The web site is DOWN.

Expected Results:  The pulse service releases the virtual server and nanny 
checking stops.  All relevant confiuration information is started on the 
backup LVS router and browsing continues.  This is what happens if the 
outside NIC is unplugged on the Primary LVS Router.

Sorry that I have resorted to calling this a bug,  I have been at this for 
quite some time trying to find my configuration fault.  But since when the 
outside NIC is unplugged, all the services transfer to the backup LVS 
properly, then I think that there is something else going on here.  I 
believe that the LVS backup should be checking both the internal and 
external NIC's on the primary LVS router.
Comment 1 Red Hat Bugzilla 2001-03-26 11:51:11 EST
>I am using Red Hat 6.2 upgraded to HA 1.0.

What do you mean by this? If you used the UPDATE option of the HA product on an
existing Linux system, you do not end up with a proper HA server. The
documentation mentions this. The UPDATE option just updates your 6.2 system to
6.2.2. 


>All that happens is that the 
>Real Servers are lost by the LVS Primary Router and web services go away.  
> However, all is fine when the public (outside NIC) is unplugged.

When a testing a defined virtual service resulting in no real server responding
(i.e. all of the servers in that service are gone), it should failover.

Can you make sure you are running the latest software? Both IPVS and piranha
have changed quite a lot since the HA 1.0 release. This includes changes to I/O
testing and fixing a memory leak. Visit http://ha.redhat.com/ and grab the
latest RPMs from the experimental area, and see if you still have this problem.
Comment 2 Red Hat Bugzilla 2001-10-14 15:14:14 EDT
Humm,... I'll do a bit of work on this and see whats up
Comment 3 Red Hat Bugzilla 2002-08-12 14:09:16 EDT
I think I've got this fixed with 0.7.0-3

see ftp://ftp.uk.linux.org/pub/linux/piranha

please note that te failover web pages were removed but the internal
functionality for failover in piranha still exists. (This was done for the AS
release of RHAT Linux where I was asked to remove the failover pages for
marketing reasons)

Phil
=--=

Note You need to log in before you can comment on or make changes to this bug.