Bug 33274 - xchat scrawls text over itself
xchat scrawls text over itself
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: xchat (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-26 13:08 EST by Stephen John Smoogen
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-20 06:04:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen John Smoogen 2001-03-26 13:08:16 EST
xchat-1.6.3-4

xchat will "uglify" itself on its left column. "Uglifying" means that text
becomes corrupted because there are 2 sets of text writing over the same
visual space. The cause seems to be in that the the timestamp widget is
"colliding" with the names widgets. This makes the left column unusable
until you move your mouse over it where it will do a partial redraw.

Sorry cant be more technical without coffee.
Comment 1 Owen Taylor 2001-07-19 19:35:57 EDT
Haven't seen this. Could you try again with the xchat-1.8 RPMS
we have now in Rawhide and see if it still occurs?
Comment 2 Mike A. Harris 2002-01-07 07:23:21 EST
I noticed that also and thought it was a bug too.  I've been told it is
a feature however, so that one can see the timestamps properly.
Depending on the location of the separator bar - nicknames and timestamps
may collide. the timestamp remains visible with the nick under until
you move it or cause it to display.

I'm not sure how it should work officially though, I can see ups and
downs to both methods.  Probably should discuss this with xchat
developers to see what their official take is on it.
Comment 3 Mike A. Harris 2002-01-20 06:04:44 EST
Ok, I talked to xchat's author, Peter Zelazny and here is his response:

> >Is it to do with overlapping timestamp/nicks? It's probably just the:
> >max_auto_indent
> >is set too low while using a large font. Something like
> >/set max_auto_indent 300
> >should fix it (when the next line appears). The default is 256, but old
> >versions had a much smaller default (which this user could still have).
 
Yeah that was it. It won't overlap if the max_auto_indent is high enough (num
of pixels) and Auto Indent is turned ON. The reason for max_auto_indent was
that some networks, with 32-length nicks, were causing it to move too far to
the right.
Comment 4 Mike A. Harris 2002-01-20 06:05:37 EST
So this is caused intentionally.  To modify just set the max_auto_indent
variable as described above, and you should be good to go.

Note You need to log in before you can comment on or make changes to this bug.