Bug 332741 - Evolution hangs if wrong password with imap/ssl
Evolution hangs if wrong password with imap/ssl
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
8
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-15 12:07 EDT by LH
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-22 09:52:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description LH 2007-10-15 12:07:10 EDT
Description of problem:
I have a mail account to which I connect using IMAP over SSL. If I enter wrong
password, tries to connect server without actually finishing or giving error
message. It just says checking for new messages. If then try to close Evolution,
it hangs and I need to use kill to stop it.


Version-Release number of selected component (if applicable):
Name   : evolution
Arch   : x86_64
Version: 2.12.0
Release: 8.fc8
Comment 1 Milan Crha 2007-10-17 11:00:26 EDT
I think it depends on the connection. When I'm trying reproduce this, then I get
prompt for a password again, with text:
------
Unable to authenticate to IMAP server.
IMAP command failed: Login failed: authentication failure

Please enter the IMAP password for ....
------

It took about 4-5 seconds on my machine, but can be longer, depending on the
server. My guess is that the Evolution isn't hanged, but waits on a response
from the server. (Some servers can have a policy to wait longer when trying to
log in with incorrect password as a protection against bots.)

Can you try to wait, say 30-60 seconds, if dialog for password will appear or not?
Comment 2 LH 2007-10-18 01:27:34 EDT
Ok. I just let it run for 5 minutes. The server I'm using is imap.tut.fi if that
helps.
Comment 3 Milan Crha 2007-10-18 04:15:21 EDT
Thanks, unfortunately, without an account there I cannot debug it.
Please try update to version 2.12.1, and install debuginfo packages too, and if
possible, make it stuck and attach to the process with gdb and attach here stack
trace for all running threads (I can provide more detailed info how to do this,
if you wish). Thanks in advance.
Comment 4 LH 2007-10-18 07:59:33 EDT
I just tried debuginfo-install evolution only to get tons of stuff like

Package openldap-debuginfo needs accesslog-2.3.so.0()(64bit), this is not available.
Package openldap-debuginfo needs auditlog-2.3.so.0()(64bit), this is not available.
Package openldap-debuginfo needs back_sql-2.3.so.0()(64bit), this is not available.
Package openldap-debuginfo needs denyop-2.3.so.0()(64bit), this is not available.
Package openldap-debuginfo needs dyngroup-2.3.so.0()(64bit), this is not available.


Sure I'd try to trace it if could get the debug symbols installed.
Comment 5 Matthew Barnes 2007-10-18 10:02:29 EDT
Try "yum install evolution-debuginfo evolution-data-server-debuginfo"
Comment 6 LH 2007-10-22 08:28:07 EDT
I just updated to latest 2.12.1-3 version and can't reproduce anymore.
Comment 7 Matthew Barnes 2007-10-22 09:52:39 EDT
Thanks for the update.  Closing as RAWHIDE.

Note You need to log in before you can comment on or make changes to this bug.