Bug 332751 - network status monitoring broken
network status monitoring broken
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F8Blocker
  Show dependency treegraph
 
Reported: 2007-10-15 12:10 EDT by Matthias Clasen
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-15 14:40:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthias Clasen 2007-10-15 12:10:49 EDT
I believe this broke because nm 0.7.0 doesn't emit all the same signals as 0.6.5
Comment 1 Matthew Barnes 2007-10-15 14:31:35 EDT
With Evolution open, I tried disabling and re-enabling networking with
NetworkManager and Evolution seemed to follow along.  It updated its online /
offline icon (lower left corner) each time I changed something.

Maybe the API didn't break after all?

NetworkManager-0.7.0.3-svn2970.fc8
evolution-2.12.0-8.fc8
Comment 2 Matthew Barnes 2007-10-15 14:36:06 EDT
I believe Evolution uses NetworkManager-glib, in case that provides any clues.
Comment 3 Matthew Barnes 2007-10-15 14:40:30 EDT
Demoed this working to Matthias and we agreed to close the bug.

The NetworkManager-glib API hasn't changed, so we're good for NM 0.7.0.

Note You need to log in before you can comment on or make changes to this bug.