Bug 3329 - could not create dir /etc/X11/fs/.xauth
could not create dir /etc/X11/fs/.xauth
Status: CLOSED DUPLICATE of bug 2423
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
6.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-06-08 00:33 EDT by gmourani
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-06-14 16:42:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description gmourani 1999-06-08 00:33:41 EDT
DESCRIPTION:
After installation of RH60, when rebooting the system for
the first time, this message appear in the log file
/var/log/messages "could not create dir /etc/X11/fs/.xauth"
This is a new install and the /etc/X11/fs exist with the
file config. It doesn't cause problems with my XFree86 but I
can see the message (could not create dir
/etc/X11/fs/.xauth) in the log file. I think that the system
cant create the file in the directory because
it doesn't have permission to do, the /etc/X11/fs is 755 by
default when your install Linux for the first time. If I
change the permission of this folder for 775 it's work
but am not sure if it can by a problem with the security of
the system? Strange. xfs is run by the xfs user, which of
course does not have root priviledges, but /etc/X11/fs is
owned by root.root. Why enabling write permission for the
root group makes the error go away makes no sense because
xfs's group is xfs.

RedHat Linux 6.0
Gnome
xfs, atd, gpm, inet, named, nfs, routed, smb, sshd, crond,
halt, keytable, netfs, portmaps, sendmail, snmpd, syslog,
function, httpd, killall, network, squid, single, random.
SCSI Drive
pc x86 400MHz single Processor
Monterboard Asus P2-BLS

Tanks,
Gerhard Mourani
Comment 1 Preston Brown 1999-06-11 14:30:59 EDT
This will be fixed in an upcoming errata release of X.
Comment 2 Preston Brown 1999-06-14 16:42:59 EDT
*** This bug has been marked as a duplicate of 2423 ***

Note You need to log in before you can comment on or make changes to this bug.