Bug 332951 - LTC39673: 201207: Support Mellanox PCI-E 4x DDR Infiniband HCA on x/p Blades
LTC39673: 201207: Support Mellanox PCI-E 4x DDR Infiniband HCA on x/p Blades
Status: CLOSED DUPLICATE of bug 253023
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
ppc64 All
low Severity medium
: ---
: ---
Assigned To: Scott Moser
Martin Jenner
Depends On:
Blocks: 227737
  Show dependency treegraph
Reported: 2007-10-15 14:11 EDT by IBM Bug Proxy
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-11-07 14:07:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

External Trackers
Tracker ID Priority Status Summary Last Updated
IBM Linux Technology Center 39673 None None None Never

  None (edit)
Description IBM Bug Proxy 2007-10-15 14:11:00 EDT
=Comment: #0=================================================
Stephanie A. Glass <sglass&#64;us.ibm.com> - 2007-10-15 13:37 EDT
1. Feature Id 	201207
Feature Name 	Support Mellanox PCI-E 4x DDR Infiniband HCA on x/p Blades
Sponsor 	PPC
Category 	Device Drivers and IO
Request Type 	Driver - New from Upstream

2. Short Description 	A new driver - mlx4 - is required for supporting the new
Mellanox chipset on their PCI-E 4x DDR Infiniband adapter. This adapter is GAing
on Blades by 11/2007. The mlx4 driver has already been included and integrated
by the OFED community into the OFED 1.2.5 version. It is also expected to be in
kernel 2.6.24.
Architecture 	IA-64 	ppc64 	x86_64 	
Architecture Specific ? Purely Common Code	
Affects Toolchain ? no	
Affects Installer ? no	
Affects Desktop ? no	
Affects Core Kernel (not mod)? 	yes
Affects Kernel Module ? yes
3. Describe the Business Case 	This is to support the new Infiniband hardware
made available on Blades for better performance.
Performance Assistance Required? 	no
Benefits 	The adapter is to be supported through OFED 1.2.5 download in the
initial product offering. The integration with the Distro releases is desirable
for better customer deployment and services.
4. Sponsor Priority 	1
IBM Confidential 	no
Code Contribution ? 	3rd party code
Upstream Acceptance 	In Progress
Component Release Version Target 	OFED 1.2.5
Documentation Work 	yes
Delivery Mechanism 	Device Driver

5. Hardware ro Red Hat: Still to be determine

6. PM Contact: Josh Poulson, jrp@us.ibm.com, 360 857-5053

7. Technical Contact: Frank Lin, tsenglin@us.ibm.com, 512-838-8312
Comment 1 IBM Bug Proxy 2007-10-16 11:25:33 EDT
------- Comment From tsenglin@us.ibm.com 2007-10-16 11:22 EDT-------
As of today, mlx4_ib driver has made into linux mainline kernel The
mlx4_ib driver in kernel is version 0.01 dated May 1 2006. The code
was submitted to the main line kernel on May 9, 2007.

In addition to InfiniBand, the Mellanox ConnectX adapter can also be used as
an ethernet and fibre channel adapter. The driver is split into two modules.
The mlx4_core module handles the device initialization, firmware update, and
resource allocation. It also handles the sharing of resources between
InfiniBand, ethernet and fibre channel. The mlx4_ib module handles InfiniBand
specific stuff.

The two modules are placed in two different locations in the Linux kernel
source tree. Mlx4_core is placed in drivers/net/ and mlx4_ib is placed in
drivers/infiniband/hw/mlx4/ subdirectory. Both sets of code need to be
backported to RHEL5U2 kernel to make it work.

Currently, in OFED 1.2.c-11, 1.2.5, and 1.3-alpha, there are backport code for
Linux kernel 2.6.18 and 2.6.18_FC6. I tried to build OFED-1.2.5 with RHEL5U1-
rc/ppc with no luck. Certain degree of backporting is still needed to make the
mlx4_core and mlx4_ib modules build with RHEL5U1/U2 kernel.
Comment 2 Scott Moser 2007-11-05 12:57:36 EST
  Frank Lin (tsegnlin@us.ibm.com) indicated that the OFED 1.3 should support
this adapter.  Given that, I would think this qualifies as a dupe of RH bug
253023 "FEAT: RHEL5.2: OFED 1.3 support".
  Do you agree?  If so, should this bug be duped ?
Comment 3 Doug Ledford 2007-11-07 14:07:31 EST
Yes, this would correctly be a dup.

*** This bug has been marked as a duplicate of 253023 ***

Note You need to log in before you can comment on or make changes to this bug.