Bug 333011 - withlist crashes with NameError: global name 'C_' is not defined
withlist crashes with NameError: global name 'C_' is not defined
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: mailman (Show other bugs)
7
All Linux
medium Severity high
: ---
: ---
Assigned To: Tomas Smetana
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-15 15:02 EDT by Eric Smith
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version: 2.1.9-5.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-26 13:47:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Patch for F-7 (356 bytes, patch)
2007-10-16 03:31 EDT, Tomas Smetana
no flags Details | Diff

  None (edit)
Description Eric Smith 2007-10-15 15:02:18 EDT
Description of problem:

withlist, a tool provided by mailman for list maintenance, crashes with the
error "NameError: global name 'C_' is not defined"

Version-Release number of selected component (if applicable):
    mailman-2.1.9-5  (Fedora 7)
    mailman-2.1.9-7  (Rawhide)

How reproducible:

  100%

Steps to Reproduce:
1. log in as user 'mailman'  (su to root, then "su - mailman --shell /bin/bash")
2. run bin/withlist

Actual results:

Traceback (most recent call last):
  File "bin/withlist", line 297, in <module>
    main()
  File "bin/withlist", line 236, in main
    warning = C_('No list name supplied.')
NameError: global name 'C_' is not defined

Expected results:

With no arguments, withlist normally gives a help message

Additional info:

Apparently the Fedora mailman package patches a lot of instances of _( to C_(. 
It appears that this hasn't been tested in withlist.
Comment 1 Eric Smith 2007-10-15 15:04:52 EDT
I have a mailing list that is broken, and I desperately need to run fix_url.py
on it (using withlist), but currently cannot do so.  I tried to manually fix the
list by editing its configuration (using config_list to export it, edit, and
reimport), but that was not sufficient.
Comment 2 Tomas Smetana 2007-10-16 03:31:51 EDT
Created attachment 228331 [details]
Patch for F-7

I'll test this patch and commit to F-7 and devel.  The error seems to be in
Mailman for quite a long time.	Thanks for reporting.
Comment 3 Eric Smith 2007-10-16 13:29:32 EDT
Your patch solves the problem.  Thanks, Tomas!
Comment 4 Fedora Update System 2007-10-17 22:27:38 EDT
mailman-2.1.9-5.1 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update mailman'
Comment 5 Fedora Update System 2007-11-06 11:16:46 EST
mailman-2.1.9-8.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update mailman'
Comment 6 Fedora Update System 2007-11-12 19:09:28 EST
mailman-2.1.9-8.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Fedora Update System 2007-11-26 13:47:16 EST
mailman-2.1.9-5.1 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.