Bug 333021 - Wrong pcre version in build requirements for php
Summary: Wrong pcre version in build requirements for php
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: php (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: Joe Orton
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-10-15 19:05 UTC by Ingvar Hagelund
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version: 5.2.4-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-16 13:48:36 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ingvar Hagelund 2007-10-15 19:05:54 UTC
Description of problem:
The specfile for php in fedora development claims that pcre-4.5 is new enough to
build php-5.2.4. It's not.

Version-Release number of selected component (if applicable):
php-5.2.4-1 (and probably others)

How reproducible:
Rebuild php on older distro like RHEL4

Steps to Reproduce:
1. Download latest php source rpm from fedora development. Try to recompile it
2. Watch as php claims it needs pcre-6.6 or later
  
Actual results:
php won't compile

Expected results:
rpmbuild complaining that pcre is too old

Additional info:
none

Comment 1 Joe Orton 2007-10-16 13:48:36 UTC
Thanks, fixed in 5.2.4-3.


Note You need to log in before you can comment on or make changes to this bug.