Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 333021 - Wrong pcre version in build requirements for php
Wrong pcre version in build requirements for php
Product: Fedora
Classification: Fedora
Component: php (Show other bugs)
All Linux
low Severity low
: ---
: ---
Assigned To: Joe Orton
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2007-10-15 15:05 EDT by Ingvar Hagelund
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version: 5.2.4-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-10-16 09:48:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Ingvar Hagelund 2007-10-15 15:05:54 EDT
Description of problem:
The specfile for php in fedora development claims that pcre-4.5 is new enough to
build php-5.2.4. It's not.

Version-Release number of selected component (if applicable):
php-5.2.4-1 (and probably others)

How reproducible:
Rebuild php on older distro like RHEL4

Steps to Reproduce:
1. Download latest php source rpm from fedora development. Try to recompile it
2. Watch as php claims it needs pcre-6.6 or later
Actual results:
php won't compile

Expected results:
rpmbuild complaining that pcre is too old

Additional info:
Comment 1 Joe Orton 2007-10-16 09:48:36 EDT
Thanks, fixed in 5.2.4-3.

Note You need to log in before you can comment on or make changes to this bug.