Bug 333151 - Upgrading 4.5 to 5 doesn't work because of python-elementtree
Upgrading 4.5 to 5 doesn't work because of python-elementtree
Status: CLOSED CANTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: python-elementtree (Show other bugs)
4.5
All Linux
low Severity low
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-15 17:39 EDT by Gavin
Modified: 2007-11-16 20:14 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-15 17:48:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gavin 2007-10-15 17:39:10 EDT
Hi,

Trying to upgrade 4.5 to 5 but it seems python-elementtree has the same version
in both 4.5 and 5.0 but one is build for python 2.3 and the other for 2.4.
Probably because of the same version, the package is not selected for upgrade
when "yum upgrade" and the upgrade fails with:

"Error: Missing Dependency: python-abi = 2.3 is needed by package
python-elementtree"
Comment 1 Jeremy Katz 2007-10-15 17:48:53 EDT
RHEL4 doesn't include python-elementtree; you'll need to get an update from
wherever you got the package from.

Note You need to log in before you can comment on or make changes to this bug.