Bug 333241 - 'system.desktop' file packaged in more than one package
'system.desktop' file packaged in more than one package
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: fedora-logos (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: David Zeuthen
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F10Target
  Show dependency treegraph
 
Reported: 2007-10-15 18:09 EDT by Christian Krause
Modified: 2008-10-02 10:48 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-02 10:48:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
maybe fedora-logos was an old package ? No, seems to be wanted. (9.76 KB, text/plain)
2008-05-03 22:52 EDT, David Timms
no flags Details

  None (edit)
Description Christian Krause 2007-10-15 18:09:25 EDT
I've stumbled over the problem when I tried to install bluecurve-gdm-theme:

Transaction Check Error:
  file /usr/share/gdm/themes/Bluecurve/rh_logo-header.png from install of
bluecurve-gdm-theme-1.0.0-1.fc8 conflicts with file from package
fedora-logos-7.94.0-1.fc8
  file /usr/share/gdm/themes/Bluecurve/screenshot.png from install of
bluecurve-gdm-theme-1.0.0-1.fc8 conflicts with file from package
fedora-logos-7.94.0-1.fc8

It looks like, that exactly the same file is package twice: in fedora-logos as
well as in bluecurve-gdm-theme

"rpm -V fedora-logos" revealed a couple of more files which are package twice:

e.g.:
[root@localhost ~]# rpm -qf  /usr/share/applications/screensavers/system.desktop
fedora-logos-7.94.0-1.fc8
fedora-screensaver-theme-1.0.0-1.fc8

and nearly all pictures from the "infinity" theme:
[root@localhost ~]# rpm -qf /usr/share/gdm/themes/FedoraInfinity/reboot-active.png
fedora-logos-7.94.0-1.fc8
fedorainfinity-gdm-theme-8.0.0-1.fc8


Normally the files should just be packaged once. Otherwise strange effects (like
the mentioned install problem) will occur.
Comment 1 Christian Krause 2008-02-28 18:51:04 EST
Update for RAWHIDE (upcoming FC9):

problem got smaller, but the following issue is still valid:

[root@localhost ~]# rpm -qf  /usr/share/applications/screensavers/system.desktop
fedora-logos-8.0.3-1.fc9.noarch
fedora-screensaver-theme-1.0.0-1.fc8.noarch

In general a file should be only in one package... ;-)
Comment 2 petrosyan 2008-04-11 18:31:23 EDT
This bug is still present in Fedora rawhide:

$ rpm -qf /usr/share/applications/screensavers/system.desktop
fedora-logos-8.99.2-1.fc9.noarch
fedora-screensaver-theme-1.0.0-1.fc8.noarch
Comment 3 David Timms 2008-05-03 22:52:46 EDT
Created attachment 304475 [details]
maybe fedora-logos was an old package ? No, seems to be wanted.

Thought it may have been due to an f8-rawhide upgrade, however:

$ rpm -qf /usr/share/applications/screensavers/system.desktop
fedora-logos-9.0.0-2.fc9.noarch
fedora-screensaver-theme-1.0.0-1.fc8.noarch

# yum remove fedora-screensaver-theme
...
 Package		 Arch	    Version	     Repository        Size 
=============================================================================
Removing:
 fedora-screensaver-theme  noarch     1.0.0-1.fc8      installed	  18 k
Removing for dependencies:
 fedorainfinity-screensaver-theme  noarch     1.0.0-1.fc8      installed       

 102 k
 gnome-screensaver	 i386	    2.22.1-1.fc9     installed	       3.3 M

# yum install gnome-screensaver
...
 Package		 Arch	    Version	     Repository        Size 
=============================================================================
Installing:
 gnome-screensaver	 i386	    2.22.1-1.fc9     rawhide	       1.8 M
Installing for dependencies:
 fedora-screensaver-theme  noarch     1.0.0-1.fc8      rawhide		 9.6 k
 fedorainfinity-screensaver-theme  noarch     1.0.0-1.fc8      rawhide	       

  83 k

# rpm -qf /usr/share/applications/screensavers/system.desktop
fedora-logos-9.0.0-2.fc9.noarch
fedora-screensaver-theme-1.0.0-1.fc8.noarch
Comment 4 Bug Zapper 2008-05-13 23:24:48 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Matthias Clasen 2008-10-02 10:32:59 EDT
Odd, thats the only file included in fedora-screensaver-theme, and its duplicated in fedora-logos. 

We should probably just kill fedora-screensaver-theme

Note You need to log in before you can comment on or make changes to this bug.