This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 333251 - s-c-d- puts wrong driver for dual-head system in xorg.conf
s-c-d- puts wrong driver for dual-head system in xorg.conf
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drivers (Show other bugs)
8
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-15 18:19 EDT by Evgueni Souleimanov
Modified: 2008-07-16 12:12 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-16 12:12:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/Xorg.0.log from F8test3 KDE Live (13.91 KB, text/plain)
2007-10-29 12:06 EDT, Evgueni Souleimanov
no flags Details

  None (edit)
Description Evgueni Souleimanov 2007-10-15 18:19:49 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.8.1.6) Gecko/20070725 Firefox/2.0.0.6

Description of problem:
When I boot from Fedora 8 KDE LiveCD, the GUI boot process works fine, but after that, the GUI does not start and the system remains in text mode (localhost login: prompt). I log in, edit xorg.conf and replace the display driver with the correct one. After that, I can bring the system into graphic mode (init 3 ; init 5).

Version-Release number of selected component (if applicable):
system-config-display-1.0.51-1.fc7

How reproducible:
Always


Steps to Reproduce:
1. Boot from LiveCD
2. GUI boot worked fine, graphical progressbar, with the "Show Details" link
3. After the progressbar, the system shows text login (fedora login:) prompt.
4. Log in, 
5. su
6. vim /etc/X11/xorg.conf , replace the driver in Section "Device", save the file
7. init 3
8. init 5



Actual Results:
I get the GUI only after performing all the steps to reproduce.

Expected Results:
I should get the GUI just by booting the LiveCD.

Additional info:
BIOS has this setting:

Primary graphics adapter: AGP

lspci listing:

=====
00:00.0 Host bridge: Intel Corporation 82865G/PE/P DRAM Controller/Host-Hub Interface (rev 02)
00:01.0 PCI bridge: Intel Corporation 82865G/PE/P PCI to AGP Controller (rev 02)
00:1d.0 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #3 (rev 02)
00:1d.3 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #4 (rev 02)
00:1d.7 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB2 EHCI Controller (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev c2)
00:1f.0 ISA bridge: Intel Corporation 82801EB/ER (ICH5/ICH5R) LPC Interface Bridge (rev 02)
00:1f.1 IDE interface: Intel Corporation 82801EB/ER (ICH5/ICH5R) IDE Controller (rev 02)
00:1f.3 SMBus: Intel Corporation 82801EB/ER (ICH5/ICH5R) SMBus Controller (rev 02)
00:1f.5 Multimedia audio controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) AC'97 Audio Controller (rev 02)
01:00.0 VGA compatible controller: nVidia Corporation NV11 [GeForce2 MX/MX 400] (rev b2)
02:05.0 Ethernet controller: 3Com Corporation 3c940 10/100/1000Base-T [Marvell] (rev 12)
02:09.0 VGA compatible controller: Matrox Graphics, Inc. MGA 2164W [Millennium II]
02:0b.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
02:0d.0 Ethernet controller: VIA Technologies, Inc. VT86C100A [Rhine] (rev 06)
=====

lspci tree listing:

=====
-[0000:00]-+-00.0  Intel Corporation 82865G/PE/P DRAM Controller/Host-Hub Interface
           +-01.0-[0000:01]----00.0  nVidia Corporation NV11 [GeForce2 MX/MX 400]
           +-1d.0  Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #1
           +-1d.1  Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #2
           +-1d.2  Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #3
           +-1d.3  Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #4
           +-1d.7  Intel Corporation 82801EB/ER (ICH5/ICH5R) USB2 EHCI Controller
           +-1e.0-[0000:02]--+-05.0  3Com Corporation 3c940 10/100/1000Base-T [Marvell]
           |                 +-09.0  Matrox Graphics, Inc. MGA 2164W [Millennium II]
           |                 +-0b.0  Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+
           |                 \-0d.0  VIA Technologies, Inc. VT86C100A [Rhine]
           +-1f.0  Intel Corporation 82801EB/ER (ICH5/ICH5R) LPC Interface Bridge
           +-1f.1  Intel Corporation 82801EB/ER (ICH5/ICH5R) IDE Controller
           +-1f.3  Intel Corporation 82801EB/ER (ICH5/ICH5R) SMBus Controller
           \-1f.5  Intel Corporation 82801EB/ER (ICH5/ICH5R) AC'97 Audio Controller
=====

xorg.conf generated after I boot the LiveCD (not working!)

=====
# Xorg configuration created by system-config-display

Section "ServerLayout"
	Identifier     "Default Layout"
	Screen      0  "Screen0" 0 0
	InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "InputDevice"
	Identifier  "Keyboard0"
	Driver      "kbd"
	Option	    "XkbModel" "pc105"
	Option	    "XkbLayout" "us"
EndSection

Section "Device"
	Identifier  "Videocard0"
	Driver      "mga"
EndSection

Section "Screen"
	Identifier "Screen0"
	Device     "Videocard0"
	DefaultDepth     24
	SubSection "Display"
		Viewport   0 0
		Depth     24
	EndSubSection
EndSection
=====

xorg.conf after my editing (this one works):

=====
# Xorg configuration created by system-config-display

Section "ServerLayout"
	Identifier     "Default Layout"
	Screen      0  "Screen0" 0 0
	InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "InputDevice"
	Identifier  "Keyboard0"
	Driver      "kbd"
	Option	    "XkbModel" "pc105"
	Option	    "XkbLayout" "us"
EndSection

Section "Device"
	Identifier  "Videocard0"
	Driver      "nv"
EndSection

Section "Screen"
	Identifier "Screen0"
	Device     "Videocard0"
	DefaultDepth     24
	SubSection "Display"
		Viewport   0 0
		Depth     24
	EndSubSection
EndSection
=====

xorg.conf I use on my hard drive install (made it by hand, because s-c-d GUI got my cards wrong too - maybe bug #218144 is related to this?):

=====

# Xorg configuration created by pyxf86config

Section "ServerLayout"
	Identifier     "Dual-Head Layout"
	Screen      0  "Screen0" 1152 0
	Screen      1  "Screen1" 0 0
	InputDevice    "Keyboard0" "CoreKeyboard"
	Option	    "Xinerama" "on"
	Option	    "Clone" "off"
EndSection

Section "InputDevice"
	Identifier  "Keyboard0"
	Driver      "kbd"
	Option	    "XkbModel" "pc105"
	Option	    "XkbLayout" "us,ru"
	Option	    "XkbVariant" ",winkeys"
	Option	    "XkbOptions" "grp:lwin_toggle,grp_led:scroll"
EndSection

Section "Device"
	Identifier  "Videocard0"
	Driver      "nv"
	BusID       "PCI:1:0:0"
EndSection

Section "Device"
	Identifier  "Videocard1"
	Driver      "mga"
	BusID       "PCI:2:9:0"
EndSection

Section "Screen"
	Identifier "Screen0"
	Device     "Videocard0"
	DefaultDepth     24
	SubSection "Display"
		Viewport   0 0
		Depth     24
		Modes    "1280x1024" "1280x960" "1280x800" "1152x864" "1152x768" "1024x768" "800x600" "640x480"
	EndSubSection
EndSection

Section "Screen"
	Identifier "Screen1"
	Device     "Videocard1"
	DefaultDepth     24
	SubSection "Display"
		Viewport   0 0
		Depth     24
		Modes     "1152x864" "1152x768" "1024x768" "800x600" "640x480"
	EndSubSection
EndSection
=====

These bugs may be related to mine: #194322 #218144 #291281.
Comment 1 Evgueni Souleimanov 2007-10-15 18:25:04 EDT
I cannot install Fedora 6, 7 and 8 in GUI mode, unless I leave only one graphics
card in the computer, to prevent this bug from being triggered.

The problem can also be reproduced in Fedora 7 LiveCD.
Comment 2 Matěj Cepl 2007-10-29 10:10:05 EDT
Can we get also your /var/log/Xorg.0.log as an attachment to this bug, please? 
Thank you.
Comment 3 Evgueni Souleimanov 2007-10-29 12:06:23 EDT
Created attachment 241981 [details]
/var/log/Xorg.0.log from F8test3 KDE Live

I copied this file after logging in in text mode (GUI failed to start).
Comment 4 Jesse Barnes 2008-01-10 18:26:30 EST
I don't see how this is an intel problem since you're using nv and mga?
Comment 5 Evgueni Souleimanov 2008-01-11 09:36:01 EST
(In reply to comment #4)
> I don't see how this is an intel problem since you're using nv and mga?

I don't see where the report says that this is an Intel problem (apart from the
Intel components shown in the lspci listings).
Comment 6 Matěj Cepl 2008-01-14 05:35:19 EST
Jesse, ehm, this is not the reporter's problem, but this lowly bugmaster screwed
up. I am actually not sure, whom to blame in this case of two different video
cards, so reassigning to xorg-x11-drivers component. Ajax?
Comment 7 Evgueni Souleimanov 2008-04-29 13:27:41 EDT
It looks like the problem is no longer there when I am trying Fedora 9 Alpha
LiveCD and Fedora 9 Preview LiveCD. I get the screen to the first card, nv.
Comment 8 Matěj Cepl 2008-07-16 12:12:32 EDT
sorry, forgot to close.

Note You need to log in before you can comment on or make changes to this bug.