Bug 3333 - RH 6.0 Sun4c upgrade hangs prior to file copy
RH 6.0 Sun4c upgrade hangs prior to file copy
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
sparc Linux
medium Severity medium
: ---
: ---
Assigned To: Matt Wilson
Depends On:
  Show dependency treegraph
Reported: 1999-06-08 09:04 EDT by tom_cooper
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2000-06-16 11:34:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description tom_cooper 1999-06-08 09:04:04 EDT
From: Cooper, Tom [mailto:tom.cooper@marriott.com]
Sent: Monday, June 07, 1999 9:12 AM
To: 'sparc-list@redhat.com'
Subject: FW: upgrade of 5.1 to 6.0

I've got a Sun ELC (Sun4c arch) with RH 5.1 installed.  Over
the weekend I
attempted to do an upgrade of that machine, and failed.

When I ran the upgrade, I went through the process of
selecting packages,
and cleared the dialog that told me an installation log
would be written to
the /tmp directory.

After that, nothing happened.  I waited a couple of hours, I
tried again, I
tried an install via ftp.  Nothing worked.  All failed with
the same

Has anyone seen this?

This message reflects the personal views and opinions of the
author only,
and not necessarily those of any organizaion to which the
author is

Comment 1 Jay Turner 1999-06-29 10:00:59 EDT
Please provide us with any messages that are appearing on the virutal
consoles that relate to this problem.
Comment 2 tom_cooper 1999-08-13 10:29:59 EDT
it appears, based on sparc-list traffic that this is an issue that
affects others, as well.  Apparently the boxen hang while building the
package list because they seem to run out of memory.

This is a problem on ELC, and IPX platforms.

Is someone addressing this?
Comment 3 tom_cooper 1999-08-13 10:37:59 EDT
It's been quite some time since I last attempted this.  I don't recall
_any_ messages on the VCs.

I'll try to re-run this upgrade over the weekend, and report my
Comment 4 Stephen P. Cohen 1999-08-13 10:40:59 EDT
Loading 6.0 onto my IPX with 32Mb ran successfully.  Of course, when
increasing it to 64Mb, it still correctly loads.  Either way, the
verification of package dependancies does take a very long time.
Comment 5 tom_cooper 1999-08-17 16:46:59 EDT
it appears, based on sparc-list traffic that this is an issue that
affects others, as well.  Apparently the boxen hang while building the
package list because they seem to run out of memory.

This is a problem on ELC, and IPX platforms.

Is someone addressing this?
Comment 6 tom_cooper 1999-08-31 16:55:59 EDT
I retried the upgrade, and found lots of output on the VC's (of
course.)  How can I capture that data to/from a file?  My mouse
doesn't seem to be working during the upgrade, so I don't know how to
cut/paste info.

Any ideas?  Is there something I could look for?  Please don't tell me
that I need to key in all the screen data from VC2 and VC3.....

Thanks for the help...

------- Additional Comments From   09/24/99 19:04 -------
I have the same problem on SparcStation 1.
The last message in VC5 is:
Writing inode tables: done
Writing superblocks and filesystem accounting information: done

------- Additional Comments From   09/25/99 14:57 -------
From: Igor Lemm at i.lemm@hccnet.nl (the Netherlands)

Tried with and without formating on Sparcstion 1 (28 Mb): same result.
In VC 1 after about 1 hour:
install exited abnormally -  received signal 10
sending termination signals: done
sending kill signals: done
unmounting file systems ...

you may safely reboot your system

------- Additional Comments From   10/09/99 12:38 -------
From: Igor Lemm at i.lemm@hccnet.nl

And now for the solution ....

Make a /tmp/install.log before you hit the last question-screen
(might not be important after all). The installation scripts
indicates to use this file, yet writes in /mnt/tmp/install.log.

Do not install any packages and do not choose for manual selection.
Only the bare minimum. At my SparcStation 1, ROM 1.0, 28 MB this
started to install RedHat 6.0. Herafter you have to manually install
aditional packages, using RPM. Try kdebase* for a start and
recursively work your way through all the needed packages. This is
not simple because dependecies are stated as libs or files and not as
packages. Look at the names carefully !

At this moment I have got RedHat 6.0 and even KDE up and running !
Of course is very slooooowwwww.

------- Additional Comments From   10/25/99 14:33 -------
I have the same problem with new installation of RH 6.0/SPARC via FTP
on IPC with 32 MB of RAM.  The installation hangs when I try to
choose something more than the default set of packages.
It would be great to get complete solution to this problem.
Piotr Kowalski
Comment 7 Jay Turner 2000-02-08 07:12:59 EST
The crash which is reported in this bug posting (the signal 10) is a result of a
bad memory access, probably as a result of running out of memory on the machine.

As for the comment about creating a /tmp/install.log file before starting the
actual package installation, this is totally and completly wrong.  The message
says that the installer will write the log to "/tmp/install.log" because after
the installation, when someone would want to look at this log file, that is
indeed where it is located.  However, during the actual installation, the root
filesystem is actually mounted at "/mnt/" so the installer actually does write
to "/mnt/tmp/install.log" as that corresponds to "/tmp/install.log" after

This bug is getting closed out due to not being a bug, just a memory limitation
on the machine.
Comment 8 tom_cooper 2000-02-08 08:57:59 EST
As the original reporter of this bug, I am not happy that it was simply
declared "not a bug."  My ELC still does not run 6.x because of this problem.
Additionally, I never got any feedback about how to report more information to
the developers.

Please reopen this bug report, and help me deliver the right information to
development so that my problem can be fixed.


Tom Cooper
Comment 9 Jay Turner 2000-03-01 06:34:59 EST
If you are still having problem on your machine and it is not related to memory
problems (that is, you have at least 16M of memory for a CDROM/NFS installation
and 32M for a FTP/HTTP/Hard Drive installation) then please submit any messages
that you are getting on the virtual consoles.

I am able to install 6.1 on the ELC that we have in the lab without fail, so
please provide any information that you can to help replicate this.
Comment 10 tom_cooper 2000-03-01 07:30:59 EST
Well, it's been a while since I've futzed with it.  My ELC has 64MB RAM, and
was running 5.1 fine when I attempted the upgrade.  The hard diisk failed, and
I have replaced it, but have not gotten RH6x to install properly.

I do recall that I've tried 6.0 and 6.1 without success, and that I requested a
way to capture electronically the information on the VCs (see the bug notes for
my message asking for help with that.)

As it stands, I'm sure that it will fail if I try it again.  Please tell me how
to capture the VC info.  I have tried ftp, http, and hard disk installations

Please advise.
Tom Cooper

Note You need to log in before you can comment on or make changes to this bug.