Bug 333321 - vpnc will not accept password and authenticate
vpnc will not accept password and authenticate
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: vpnc (Show other bugs)
7
i386 Linux
low Severity high
: ---
: ---
Assigned To: Tomas Mraz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-15 20:50 EDT by Sean Hyde
Modified: 2008-04-03 04:48 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-03 04:48:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sean Hyde 2007-10-15 20:50:04 EDT
Description of problem:


Version-Release number of selected component (if applicable):
vpnc-0.4.0-2.fc7.i386

How reproducible:
Every time I try to use this, I get authentication unsuccessful

Steps to Reproduce:
1.Create the conf file for access
2.Try to vpnc using that conf file
3.Password within conf file is not accepted.  It asks for the password two more
times and then fails stating that authentication was unsuccessful.
  
Actual results:
I can use the same conf file in fedora 6 and it connects fine.  With the conf
file in fedora 7, I get the error described above.

Expected results:
I need to be able to use the vpnc with fedora 7.

Additional info:
Comment 1 Tomas Mraz 2007-10-16 03:33:11 EDT
How does your /etc/vpnc/default.conf look like? Of course without the actual
password and IPsec secrets.
Comment 2 Sean Hyde 2007-10-16 08:10:19 EDT
IPSec gateway <ipaddress entered here>
IPSec ID <id entered here>
IPSec secret <secret entered here>
Domain <our domain here>
# your username goes here:
Xauth username <vpnUserName>
Xauth password <vpnPassword>

I have information entered in all of these fields that works everywhere except
fedora 7.
Comment 3 Tomas Mraz 2007-10-16 12:03:03 EDT
Is it possible that you don't have a one and only one space character between
'Xauth password' and the actual password?
I cannot reproduce the problem.
Comment 4 Sean Hyde 2007-10-16 21:08:56 EDT
No, I have exactly one space between the Xauth password and my password.  I have
tried commenting out the password so I have to manually enter it as well and
still get the same response.  It asks me to enter it twice and then says
'authentication unsuccessful'.

There are a couple of us that are having this issue.  We have tried everything
we can think of and searched for similar problems and cannot find it.  There are
multiple personnel with vpn accounts, but most of them use windows and a couple
use fedora 6, and they can connect without issue.
Comment 5 Tomas Mraz 2007-10-17 03:16:03 EDT
So even entering the password manually doesn't help. Can you try to recompile
http://download.fedora.redhat.com/pub/fedora/linux/releases/test/7.92/Fedora/source/SRPMS/vpnc-0.5.1-1.fc8.src.rpm
whether it helps?
Comment 6 Sean Hyde 2007-10-17 22:37:19 EDT
I am not overly familiar with compiling from source.  Can you provide a few
details for how to get started?  I tried the following:

rpm -ivh vpnc-0.5.1-1.fc8.src.rpm

After adding kojibuilder user and group, I was able to get this process to
complete, but it does not create a folder that I can locate to run the
configure, make and make install commands.

Any advice you can provide for getting this started would be helpful and then I
will try to see if this solves the authentication problem.

Thanks.
Comment 7 Tomas Mraz 2007-10-18 02:49:49 EDT
You can download the binary rpms from koji. I did a scratch build of the F8
package for Fedora 7.

http://koji.fedoraproject.org/koji/taskinfo?taskID=201608
Comment 8 Sean Hyde 2007-10-18 22:03:39 EDT
I get the same response with the updated version .  I had someone else try it as
well, and the same result.  It acts like it connects, just does not authenticate
the Xauth password - which we know is valid since the same password works with
fc6.  Here is the version information.

vpnc version 0.5.1
Copyright (C) 2002-2006 Geoffrey Keating, Maurice Massar, others
vpnc comes with NO WARRANTY, to the extent permitted by law.
You may redistribute copies of vpnc under the terms of the GNU General
Public License.  For more information about these matters, see the files
named COPYING.
Built without openssl (certificate) support.

Supported DH-Groups: nopfs dh1 dh2 dh5
Supported Hash-Methods: md5 sha1
Supported Encryptions: null des 3des aes128 aes192 aes256
Supported Auth-Methods: psk psk+xauth

Comment 9 Tomas Mraz 2007-10-19 02:21:17 EDT
Can you please report this issue on the upstream mailing list?

https://lists.unix-ag.uni-kl.de/mailman/listinfo/vpnc-devel

Note You need to log in before you can comment on or make changes to this bug.