Bug 33350 - Xconfigurator problem persits from Bug report #32219
Xconfigurator problem persits from Bug report #32219
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: Xconfigurator (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Preston Brown
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-26 22:06 EST by adler
Modified: 2007-04-18 12:32 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-26 22:06:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description adler 2001-03-26 22:06:46 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.2-0.1.25smp i686)


I've downloaded Xconfigurator 4.9.19-1 from rawhide and it still has the
problem of having to manually edit the /etc/X11/XF86Config-4 file.

Reproducible: Always
Steps to Reproduce:
1.Run Xconfigurator
2.Select 24pbb all resolutions and nothing else (i.e. not 16bpp)
3.
	

The behavior is better with this latest version of Xconfigurator. If I tell
Xconfigurator to probe my card and then select the default 1600x1200 24bpp
resolution, then it generates the proper /etc/X11/XF86Config-4 file. But if
I override the default of 1 resolution setting at 24bpp, and then choose to
have all settings allowed for 24bpp, an /etc/X11/XF86Config-4 file is
generated with a default depts of 24bpp at 640x480 resolution, at which
point I have to go into the file, edit it and change the default depth to
24. Again, this is a trivial change, but could annoy the
non-emacs/non-sysadmin non-expert type.

I've got a g450 card and an a viewsonic PT810-2 monitor. (Also,
Xconfigurator does not find my monitor properly and I have to select it by
hand. I'm not sure if this is because my monitor is rather old and does not
have a query feature.)
Comment 1 Preston Brown 2001-03-27 12:08:41 EST
I can't reproduce this with 4.9.25 on a 16 meg G450 today.  I followed the 
steps you did above -- saying "no" to the autoprobed 1600x1200 @24bpp, and 
manually selecting all 24bpp resolutions.  The following device section was 
written to XF86Config-4:

Section "Screen"
        Identifier "Screen0"
        Device "Matrox|MGA G450 AGP"
        Monitor "Iiyama A102GT, VisionMasterPro 502"
        DefaultDepth 24
        Subsection "Display"
                Depth 24
                Modes "1600x1200" "1400x1050" "1280x1024" "1152x864" "1024x768"
"800x600" "640x480"
        EndSubSection
EndSection

And the server properly starts at 1600x1200, 24 bit color.

Note You need to log in before you can comment on or make changes to this bug.