Bug 33369 - hdf5-1.4 won't compile
Summary: hdf5-1.4 won't compile
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gcc (Show other bugs)
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-03-27 12:26 UTC by Paul Johnson
Modified: 2007-04-18 16:32 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-27 13:06:25 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Paul Johnson 2001-03-27 12:26:24 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.2.16-22 i686)


This SRPM file for the NCSA's data format library "HDF5" will compile with
gcc-2.95.3, but not with gcc-2.96.69:
http://lark.cc.ukans.edu/~pauljohn/Swarm/miscSupportSoftware/hdf5-1.4.0-1.src.rpm

Reproducible: Always
Steps to Reproduce:
1. get my srpm file above
2. rpm -ivh hdf5-1.4.0-1.src.rpm
3. In your SPEC directory, type rpm -ba hdf5-1.4.0.spec

	

Actual Results:  compile fails, NCSA staff correctly blame gcc

Expected Results:  should compile!

Comment 1 Jakub Jelinek 2001-03-27 13:06:21 UTC
You did not specify what exactly it fails on.
What I saw is that it fails after dependency making, which is a result of
HDF's braindamaged dependency making machinery, when it is build outside
of source directory, it works fine and whole make succeeds
(ie.
cd hdf5-1.4.0
mkdir obj; cd obj
CC=gcc ../configure --disable-hsizet --prefix=/usr/local
).
What hdf does is that it gets totally foobar if srcdir = ., because then
it changes the dependencies with
sed 's% $(srcdir)/% $$(srcdir)/%g'
so some dependencies look like $(srcdir)usr/include/features.h etc.


Note You need to log in before you can comment on or make changes to this bug.