Bug 333811 - Thinkpad x31 panics upon startup
Thinkpad x31 panics upon startup
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
All Linux
high Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-16 05:56 EDT by Lubomir Kundrak
Modified: 2007-12-06 19:04 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-06 19:04:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lubomir Kundrak 2007-10-16 05:56:23 EDT
Description of problem:

After successfull installation, the start of X31 goes like:

INIT: version 2.86 booting
                Welcome to Fedora 
                Press 'I' to enter interactive startup.
Nastavuji hodiny  (utc): Út říj 16 11:40:20 CEST 2007 [  OK  ]
Spouštím udev: BUG: unable to handle kernel paging request at virtual address
6b6b6b83
printing eip: c0448ff0 *pde = 00000000 
Oops: 0000 [#1] SMP 
Modules linked in: snd_seq_dummy snd_intel8x0m snd_ac97_codec ac97_bus
snd_seq_oss snd_seq_midi_event snd_seq snd_seq_device snd_pcm_oss snd_mixer_oss
snd_pcm snd_timer irda ipw2100 snd parport_pc crc_ccitt soundcore parport
i2c_i801 floppy ieee80211 iTCO_wdt snd_page_alloc firewire_ohci i2c_core e1000
ieee80211_crypt ac firewire_core battery video iTCO_vendor_support output
crc_itu_t button thinkpad_acpi hwmon sg sr_mod cdrom ata_generic ata_piix libata
sd_mod scsi_mod ext3 jbd mbcache uhci_hcd ohci_hcd ehci_hcd
CPU:    0
EIP:    0060:[<c0448ff0>]    Not tainted VLI
EFLAGS: 00010002   (2.6.23-6.fc8 #1)
EIP is at mark_lock+0x1f/0x472
eax: 6b6b6b6b   ebx: dfc09380   ecx: 00000004   edx: 00000010
esi: dfc08d60   edi: 00000004   ebp: c17edea8   esp: c17ede84
ds: 007b   es: 007b   fs: 00d8  gs: 0000  ss: 0068
Process events/0 (pid: 6, ti=c17ed000 task=dfc08d60 task.ti=c17ed000)
Stack: 154234a1 00000000 00000246 6b6b6b6b c17edea8 00000010 00000246 6b6b6b6b 
       dfc08d60 c17edefc c0449fb3 00000001 00000246 c08d0e98 dfc08d60 c17edf14 
       00000000 00000000 dfd40210 00000001 dfc08d60 dfc09380 dfc08d60 00000000 
Call Trace:
 [<c0406463>] show_trace_log_lvl+0x1a/0x2f
 [<c0406513>] show_stack_log_lvl+0x9b/0xa3
 [<c04066d3>] show_registers+0x1b8/0x289
 [<c04068af>] die+0x10b/0x23e
 [<c063638c>] do_page_fault+0x51c/0x5ed
 [<c0634ab2>] error_code+0x72/0x78
 [<c0449fb3>] __lock_acquire+0x4de/0xc67
 [<c044abb6>] lock_acquire+0x7b/0x9e
 [<c063434d>] _spin_lock_bh+0x33/0x5d
 [<c05dd6c6>] dev_activate+0x74/0xa6
 [<c05d7a4a>] __linkwatch_run_queue+0x149/0x183
 [<c05d7aa4>] linkwatch_event+0x20/0x27
 [<c043b61f>] run_workqueue+0x7d/0x129
 [<c043bfdf>] worker_thread+0xbb/0xc8
 [<c043e7ff>] kthread+0x3b/0x64
 [<c0405ee3>] kernel_thread_helper+0x7/0x10
 =======================
Code: f0 e8 58 f6 ff ff 5b 5e 5b 5e 5d c3 55 89 e5 57 89 cf 56 89 c6 53 89 d3 83
ec 18 c7 45 f0 01 00 00 00 d3 65 f0 8b 42 08 8b 55 f0 <85> 50 18 0f 85 2a 04 00
00 90 fe 0d 30 c9 71 c0 79 0d f3 90 80 
EIP: [<c0448ff0>] mark_lock+0x1f/0x472 SS:ESP 0068:c17ede84
Kernel panic - not syncing: Fatal exception in interrupt

Version-Release number of selected component (if applicable):

2.6.23-6.fc8
Comment 1 Lubomir Kundrak 2007-10-16 06:06:23 EDT
What's interesting is that when I ran udevd --verbose to find out what caused
the crash, it didn't happen. I suspect this might be a race condition and the
slowdown of the pile of input fed into serial console prevented triggering the
crash.
Comment 2 Chuck Ebbert 2007-10-16 19:05:16 EDT
It looks like something has scheduled a linkwatch event and by the time it runs
the device has been freed...
Comment 3 Lubomir Kundrak 2007-10-17 05:50:45 EDT
After reinstall of Rawhide with the very same kickstart configuration and the
very same kernel I am no longer able to reproduce this. I did not try much
though; I just normally booted the machine.

Note You need to log in before you can comment on or make changes to this bug.