Bug 333821 - Export directory with spaces in the name causes problems
Export directory with spaces in the name causes problems
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: autofs (Show other bugs)
5.0
All Linux
low Severity medium
: ---
: ---
Assigned To: Ian Kent
Brock Organ
:
Depends On: 244588
Blocks: 426498
  Show dependency treegraph
 
Reported: 2007-10-16 05:57 EDT by Ian Kent
Modified: 2008-05-21 10:38 EDT (History)
2 users (show)

See Also:
Fixed In Version: RHBA-2008-0354
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 10:38:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to add quoting for exports gathered by hosts map. (1.51 KB, patch)
2007-10-16 05:57 EDT, Ian Kent
no flags Details | Diff

  None (edit)
Description Ian Kent 2007-10-16 05:57:00 EDT
+++ This bug was initially created as a clone of Bug #244588 +++

Description of problem:
Last day I was exporting, using NFS, the DVD of Fedora 7,
which is located usually as "/media/Fedora 7 x86_64 DVD".
The export was successful, I could mount remotely the directory
using the standard mount procedure, that is:

mount "server:/media/Fedora 7 x86_64 DVD" /mnt

The /etc/exports had the export name also between "",
something like:

"/media/Fedora 7 x86_64 DVD" 192.168.0.3(ro,sync)

Problem was with automount, it reported an error like "cannot
find location" (or similar, I do not have the logs here).
Nevertheless, starting /etc/auto.net manually, it was clear that
the script cut the directory name at the first space.
The output was something like:

-fstype...
  Fedora ... server:/Fedora \
...

Which, of course, is nonsense.

Version-Release number of selected component (if applicable):
5.0.1-9

How reproducible:
Always

Steps to Reproduce:
1.
Create a directory with spaces in the name, like "my dir".
2.
Export with NFS.
3.
Try to automount remotely.
  
Actual results:
The client cannot mount the export.

Expected results:
It should be mounted, since manual mount works.

Additional info:
The problem seems to be, at least in part, in the fact that
/etc/auto.net uses "$1" in the "awk" printing. This means that
only the first string of the record is printed, which, in our
case, is only a part of the exported directory.
I tried to add "" and "\ ", but it didn't seem to work, maybe
there is a problem also in the software part that reads the
output of /etc/auto.net (or I made something wrong).

-- Additional comment from ikent@redhat.com on 2007-06-17 23:23 EST --
(In reply to comment #0)
> Description of problem:
> Last day I was exporting, using NFS, the DVD of Fedora 7,
> which is located usually as "/media/Fedora 7 x86_64 DVD".
> The export was successful, I could mount remotely the directory
> using the standard mount procedure, that is:
> 
> mount "server:/media/Fedora 7 x86_64 DVD" /mnt
> 
> The /etc/exports had the export name also between "",
> something like:
> 
> "/media/Fedora 7 x86_64 DVD" 192.168.0.3(ro,sync)
> 
> Problem was with automount, it reported an error like "cannot
> find location" (or similar, I do not have the logs here).
> Nevertheless, starting /etc/auto.net manually, it was clear that
> the script cut the directory name at the first space.
> The output was something like:
> 
> -fstype...
>   Fedora ... server:/Fedora \
> ...
> 
> Which, of course, is nonsense.

Does this work if "-hosts" is used instead of "auto.net"?
At some point the auto.net script won't be installed
anymore so you need to migrate maps to use the hosts
map instead.

For example:

/net   -hosts

instead of 

/net /etc/auto.net

Ian


-- Additional comment from piergiorgio.sartor@nexgo.de on 2007-06-18 02:21 EST --
(In reply to comment #1)
> Does this work if "-hosts" is used instead of "auto.net"?
> At some point the auto.net script won't be installed
> anymore so you need to migrate maps to use the hosts
> map instead.
> 
> For example:
> 
> /net   -hosts
> 
> instead of 
> 
> /net /etc/auto.net
> 
> Ian
> 

Uhm, I'm using the system out-of-the-box, so the configuration files are the
default ones.
The /etc/auto.master contains:

/net    -hosts

The /etc/auto.net is installed, as well, by default, so I assumed it is used
somewhere by the automounter.
If this is not the case, then the problem is somewhere else.

I guess you should be able to reproduce easily, do you?


piergiorgio

-- Additional comment from piergiorgio.sartor@nexgo.de on 2007-06-18 02:26 EST --
Well, maybe to be more clear.
What I do is simply a "cd /net/server" (where "server" is the nfs server name)
on the client and I get the error.
To be more clear, if I remove the export (from the server) with spaces the above
"cd" command works (for the other exports of the server).
Also if I bind mount "/media/Fedora 7 x86_64 DVD" on something like
"/media/disk" and I export this last one, the "cd" command works.
Hope this help further.

-- Additional comment from updates@fedoraproject.org on 2007-07-16 12:53 EST --
autofs-5.0.1-17 has been pushed to the Fedora 7 testing repository.  If problems
still persist, please make note of it in this bug report.

-- Additional comment from piergiorgio.sartor@nexgo.de on 2007-07-17 14:40 EST --
I tested the updated and it seems to work properly, the exported "Fedora DVD" is
automounted without problems.
I would close the bug.


-- Additional comment from ikent@redhat.com on 2007-10-07 22:03 EST --
As per comment #5 this problem has been resolved.
Comment 1 Ian Kent 2007-10-16 05:57:00 EDT
Created attachment 228491 [details]
Patch to add quoting for exports gathered by hosts map.
Comment 2 RHEL Product and Program Management 2007-10-16 06:05:11 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 8 errata-xmlrpc 2008-05-21 10:38:14 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0354.html

Note You need to log in before you can comment on or make changes to this bug.