Bug 33391 - WORKAROUND FOUND: up2date script stopped working after several successful upgrades
Summary: WORKAROUND FOUND: up2date script stopped working after several successful upg...
Status: CLOSED DUPLICATE of bug 32301
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: up2date   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Preston Brown
QA Contact: Jay Turner
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-03-27 14:31 UTC by Need Real Name
Modified: 2015-01-07 23:44 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-27 16:17:11 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2001-03-27 14:31:55 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.75 [en] (X11; U; Linux 2.2.16-22 i686)


up2date fails with Python error:
Traceback (innermost last):
  File "/usr/sbin/up2date", line 9, in ?
    import rpm
ImportError: /usr/lib/python1.5/site-packages/rpmmodule.so: undefined
symbol: rpmSetVerbosity



Reproducible: Always
Steps to Reproduce:
1. Run up2date in xterm window
		

Actual Results:   As in description

Expected Results:  Hey, it should work :)

Python and its libraries are are latest. 

up2date-config works OK.

Comment 1 Need Real Name 2001-03-27 15:42:31 UTC
Downgrading of rpm-python from 4.0-4 to 4.02-7x solved the problem

Comment 2 Preston Brown 2001-03-27 15:54:00 UTC

*** This bug has been marked as a duplicate of 32301 ***

Comment 3 Need Real Name 2001-03-27 16:03:28 UTC
After checking with other bugs it seems that in those cases _upgrading_ 
of rpm-python solved the problem. In my case _downgrading_ provided 
workaround. The problem is reproducible. IMHO it seems that last version
of rpm-python is not compatible with last version of up2date.

Comment 4 Need Real Name 2001-03-27 16:17:06 UTC
Oops - my mistake. I did _upgraded_ rpm-python :)
So the only issue left is wrong dependancy check.
New version of up2date should require last version of rmp-python.


Comment 5 Preston Brown 2001-03-28 18:41:38 UTC

*** This bug has been marked as a duplicate of 32301 ***


Note You need to log in before you can comment on or make changes to this bug.