Bug 33392 - Latest mutt no longer polls for new messages properly.
Summary: Latest mutt no longer polls for new messages properly.
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: mutt   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-03-27 14:59 UTC by David Lawrence
Modified: 2014-03-17 02:20 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-27 23:02:37 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Config file for my mutt mail reader (4.37 KB, text/plain)
2001-03-27 15:01 UTC, David Lawrence
no flags Details

Description David Lawrence 2001-03-27 14:59:41 UTC
mutt-1.2.5i-9 no longer polls my mailboxes properly for new messages when
running for first time in a login session. If I ssh over to devserv and run
mutt from there my mailbox list properly shows boxes containing new
messages right from the start. Devserv is running 
mutt-1.2.5i-3. Both machines are using the same .muttrc file which I will
attach to this bug report. I will try downgrading the mutt on my
workstation to the same as devserv and see if it solves the problem for me.

Comment 1 David Lawrence 2001-03-27 15:01:12 UTC
Created attachment 13826 [details]
Config file for my mutt mail reader

Comment 2 Bill Nottingham 2001-03-27 16:37:57 UTC
I can't reproduce this here; it notices new mail in my mailboxes OK. Are you
using maildir, mbox, or mh?  Do you have the nfslock service started?

Comment 3 David Lawrence 2001-03-27 16:57:37 UTC
I am using mbox. Funny thing is is that I downgraded to the same version of mutt
that is currently
installed on devserv and that still did not fix the problem.

Pattern of events:
1. run xterm on local box with /home/devel nfs mounted
2. run mutt and it comes up in my inbox by default showing any new messages.
3. Then type a 'c' and '?' to show directory containing mailboxes.
4. There are not any 'N' characters next to any mailboxes even after tabbing a
couple times.
5. Bring up an xterm and ssh over to devserv.devel.
6. Repeat steps 2 and 3.
7. Many mailboxes show new messages next to them as normal.

Could this be a new NFS issue with locking or something. I did not have this
problem locally running 7.0 so now I believe it is more than just a newer mutt
package.


Comment 4 Bill Nottingham 2001-03-27 17:13:28 UTC
What happens if you sync your clock to the clock on devserv?

Comment 5 David Lawrence 2001-03-28 00:10:30 UTC
Okay it seems to be better now since my clock was in fact off from devserv.
Syncing up seems to have helped.


Note You need to log in before you can comment on or make changes to this bug.