Bug 334 - ifconfig does not run properly when rebooting
ifconfig does not run properly when rebooting
Product: Red Hat Linux
Classification: Retired
Component: linuxconf (Show other bugs)
i386 Linux
high Severity high
: ---
: ---
Assigned To: Nalin Dahyabhai
Depends On:
  Show dependency treegraph
Reported: 1998-12-07 18:23 EST by dyoung
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 1999-03-24 20:38:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description dyoung 1998-12-07 18:23:17 EST
I'm trying to setup IP aliasing on Redhat5.2 which we have
just installed.  After I type in the ifconfig and route
commands and see things working well, I decided to edit the
network-scripts to save these settings so they'll come back
when I reboot.

I created ifcfg-eth0:0 in /etc/sysconfig/network-scripts


However, after rebooting, I see this:

eth0:0    Link encap:Ethernet  HWaddr 00:A0:C9:C9:40:7A
          inet addr:  Mask:
          UP RUNNING  MTU:1500  Metric:1

Notice the IP address is wrong.  I also tried to manually
call "ifup eth0:0" and it does it correctly.  I tried to
use linuxconf and it doesn't work.  The problem seems to
occur when booting, the ifcfg-eth0:0 file is parsed

Please let me know if you need more information.


David Young
Comment 1 Aleksey Nogin 1998-12-07 21:57:59 EST
Did you try using eth0:1 instead?
Comment 2 dyoung 1998-12-08 18:47:59 EST
Yes I have tried etho0:1.  In fact, originally, I setup eth0:0
through eth0:4 and none of them work after rebooting.  Could this
be a linuxconf problem?  We are not running the default linuxconf
that came with redhat5.2.  We have updated the linuxconf rpm to
version 1.13r5
Comment 3 Jeff Johnson 1999-03-24 20:38:59 EST
There are a lot of changes between the "official" linuxconf
and the Red Hat linuxconf. This smells like one of those changes,
probably due to the quotes around the IPADDR.

Please reopen this bug if that is not the case.

Note You need to log in before you can comment on or make changes to this bug.