Bug 334121 - could not connect to server
could not connect to server
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: tinyerp (Show other bugs)
7
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Dan Horák
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-16 08:22 EDT by Frederic Hornain
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version: 4.0.3-3.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-29 15:05:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Frederic Hornain 2007-10-16 08:22:28 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.5) Gecko/20070718 Fedora/2.0.0.5-1.fc7 Firefox/2.0.0.5

Description of problem:
After having initialized the postgres instance and created a tinyerp related database and an associated db user.
I have launched the tinyerp server daemon.
then I have launched the tiny erp client.
Unfortunately, I was not able to be connected with the client to the server.
It seems the problem is linked with Python2.4 and SimpleXMLRPCServer.py.
Indeed, F7 is using Python2.5 and tinyerp prefer to use Python2.4.

Version-Release number of selected component (if applicable):
tinyerp-4.0.3-2.fc7
tinyerp-server-4.0.3-2.fc7 tinyerp-4.0.3-2.fc7

How reproducible:
Always


Steps to Reproduce:
1. install tiny erp and postgres
2. initilize the postgres instance
3. create a tiny database
4. create a tiny user for this database.
5. launch tiny erp server.
6. Try to launch tiny erp client

Actual Results:
You should have a "could not connect to server " message

Expected Results:
You should be connected to the tiny erp server

Additional info:
Comment 1 Frederic Hornain 2007-10-16 08:24:28 EDT
Have a look at http://www.mail-archive.com/tinyerp-users@tinyerp.org/msg00812.html
Comment 2 Dan Horák 2007-10-16 12:45:23 EDT
tinyerp-4.2.0-rc2 works well on F-7, so there should be a solution with patching
tinyerp only
Comment 3 Dan Horák 2007-10-17 03:08:38 EDT
New version is built - you can get it directly from
http://koji.fedoraproject.org/koji/buildinfo?buildID=21267 or wait until it is
published in updates-testing and then in updates.
Comment 4 Frederic Hornain 2007-10-17 05:09:49 EDT
Thanks a lot for your help and have fun with FC7.

Kind Regards
Frederic Hornain
Comment 5 Fedora Update System 2007-10-17 22:28:56 EDT
tinyerp-4.0.3-3.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update tinyerp'
Comment 6 Fedora Update System 2007-10-29 15:05:01 EDT
tinyerp-4.0.3-3.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.