Bug 3343 - stupid bug, if /usr/src/redhat/RPMS/i386/ is missing the build fails completely
Summary: stupid bug, if /usr/src/redhat/RPMS/i386/ is missing the build fails completely
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm   
(Show other bugs)
Version: 6.0
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Jay Turner
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-06-08 20:06 UTC by seifried
Modified: 2015-01-07 23:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-06-08 20:53:08 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description seifried 1999-06-08 20:06:26 UTC
It fails to copy the rpm there (obviously as the dir
doesn't exist), and does give an error but it is annoying
because I left a rather large rpm building overnight and it
failed. rpm should check for the destination directory it
will dump the newly created rpm into and warn if it doesn't
exist BEFORE doing all the compiling. Minor but annoying.

Comment 1 Jeff Johnson 1999-06-08 20:53:59 UTC
There's nothing stopping you from writing your specfile as
	%build
	[ ! -d %{_rpmdir}/%{_arch} ] && exit 1
if you wish this functionality. There's a limit on what
rpm can do without intelligent intervention.


Note You need to log in before you can comment on or make changes to this bug.