Bug 334321 - yumdownloader causes python tracebacks when run as user
Summary: yumdownloader causes python tracebacks when run as user
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: yum-utils   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Seth Vidal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-10-16 14:13 UTC by Julian Sikorski
Modified: 2007-11-30 22:12 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-17 05:04:19 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Julian Sikorski 2007-10-16 14:13:58 UTC
Description of problem:

jsikorski@snowball cvs]$ yumdownloader --source
--enablerepo=dribble-development-source qmc2
Loading "skip-broken" plugin
Loading "fastestmirror" plugin
Loading "fedorakmod" plugin
Loading "refresh-updatesd" plugin
Traceback (most recent call last):
  File "/usr/bin/yumdownloader", line 215, in <module>
    util = YumDownloader()
  File "/usr/bin/yumdownloader", line 41, in __init__
    self.main()
  File "/usr/bin/yumdownloader", line 49, in main
    opts = self.doUtilConfigSetup()
  File "/usr/share/yum-cli/utils.py", line 69, in doUtilConfigSetup
    (opts, self.cmds) = self._parser.setupYumConfig()
  File "/usr/share/yum-cli/cli.py", line 1210, in setupYumConfig
    self.base._getRepos(doSetup=True)
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 345, in _getRepos
    self._repos.doSetup(thisrepo)
  File "/usr/lib/python2.5/site-packages/yum/repos.py", line 58, in doSetup
    repo.setup(self.ayum.conf.cache, self.ayum.mediagrabber)
  File "/usr/lib/python2.5/site-packages/yum/yumRepo.py", line 715, in setup
    self.dirSetup()
  File "/usr/lib/python2.5/site-packages/yum/yumRepo.py", line 472, in dirSetup
    "Cannot access repository dir %s" % dir
yum.Errors.RepoError: Cannot access repository dir
//var/cache/yum/dribble-development-source


Version-Release number of selected component (if applicable):
yum-utils-1.1.7-1.fc8.noarch

How reproducible:
always

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
It used to work in the past even when the folders were not created. Anyway, some
kind of meaningful error message is welcome so that people will get informed
what the problem is.

Comment 1 Tim Lauridsen 2007-10-16 15:59:15 UTC
no need to add the --enablerepo=dribble-development-source option
using the '--source' option will auto enable the *-source repos for all enabled
repos.

it will work as normal user but using '--enablerepo' will fail.

Comment 2 Julian Sikorski 2007-10-16 16:11:44 UTC
Oh, so this must have changed - I remember having to enable yum repos manually.
Closed - Invalid?

Comment 3 Seth Vidal 2007-10-17 05:04:19 UTC
I've made a change to yumdownloader which will at least make the the error a bit
less ugly.



Note You need to log in before you can comment on or make changes to this bug.