This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 334371 - RAR v3 support in clamav violates license
RAR v3 support in clamav violates license
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: clamav (Show other bugs)
rawhide
All Linux
urgent Severity urgent
: ---
: ---
Assigned To: Enrico Scholz
Fedora Extras Quality Assurance
:
Depends On:
Blocks: FE-Legal
  Show dependency treegraph
 
Reported: 2007-10-16 10:24 EDT by Tom "spot" Callaway
Modified: 2007-12-27 08:50 EST (History)
3 users (show)

See Also:
Fixed In Version: 0.91.2-3.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-01 17:15:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tom "spot" Callaway 2007-10-16 10:24:07 EDT
While investigating the possible inclusion of a GPL'd unrar package (see
Bugzilla 319831), it was discovered that clamav contained a RAR v3
implementation that was copied/derived from the RARlabs unrar source code.
Eugene Roshal of RARlabs confirmed that they did not give permission for any RAR
v3 implementation to be used under the GPL, only under the unrar license (which
is GPL incompatible).

We need to remove this code from libclamav immediately, in all currently
maintained releases of Fedora (and EPEL, if branched).
Comment 1 Fedora Update System 2007-11-01 17:15:00 EDT
clamav-0.91.2-3.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 2 R P Herrold 2007-12-21 12:11:00 EST
How does an update release address the question of a license issue?  Shouldn't
this not have closed?
Comment 3 Tom "spot" Callaway 2007-12-21 12:14:44 EST
It addressed it because I took out the unrar code from the clamav tarball,
reported the issue to clamav upstream, and pushed a new update. :)

Note You need to log in before you can comment on or make changes to this bug.