Bug 334681 - dbus should own %{_datadir}/dbus-1/interfaces/
dbus should own %{_datadir}/dbus-1/interfaces/
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: dbus (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: David Zeuthen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-16 11:59 EDT by Kevin Kofler
Modified: 2013-03-05 22:53 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-16 12:11:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kevin Kofler 2007-10-16 11:59:55 EDT
Description of problem:
KDE 4 installs D-Bus interfaces to %{_datadir}/dbus-1/interfaces/, which leads 
to an unowned directory. I believe this directory should be owned by D-Bus.

Version-Release number of selected component (if applicable):
dbus-1.1.2-7.fc8, dbus-1.0.2-6.fc7 and all earlier builds

How reproducible:
Always

Steps to Reproduce:
1. rpm -qf /usr/share/dbus-1/interfaces/
  
Actual results:
file /usr/share/dbus-1/interfaces is not owned by any package

Expected results:
dbus-1.0.2-6.fc7
Comment 1 David Zeuthen 2007-10-16 12:11:16 EDT
This sounds like a KDE-ism; /usr/share/dbus-1/interfaces is, AFAIK, not
mentioned anywhere in any D-Bus specification or implementation notes. Also, I
recall discussion about this on the mailing list and that there was no
conclusion about it.
Comment 2 David Zeuthen 2007-10-16 12:19:04 EDT
(btw, I'm not saying this is not a useful feature but things like this needs to
happen upstream)
Comment 3 Kevin Kofler 2007-10-16 12:31:40 EDT
But all that's needed here is a directory, not any change to the upstream 
source code, and I think dbus is really the best place to own this (and Rex and 
Than both agree). I'm putting the directory into soprano now, which happens to 
be the lowest package in the dependency chain using it, but to me this looks 
like a crude hack and not a solution. We could put it into kde-filesystem, but 
that would mean soprano, which is not strictly a KDE package (but a kdesupport 
one) would have to depend on kde-filesystem for directory ownership, which is 
also ugly.
Comment 4 David Zeuthen 2007-10-16 12:44:05 EDT
(In reply to comment #3)
> But all that's needed here is a directory, not any change to the upstream 
> source code, and I think dbus is really the best place to own this (and Rex and 
> Than both agree). I'm putting the directory into soprano now, which happens to 
> be the lowest package in the dependency chain using it, but to me this looks 
> like a crude hack and not a solution. We could put it into kde-filesystem, but 
> that would mean soprano, which is not strictly a KDE package (but a kdesupport 
> one) would have to depend on kde-filesystem for directory ownership, which is 
> also ugly.

KDE is doing something that was discussed on the upstream mailing list and not
agreed to by upstream. IMNSHO it's basicly wrong what KDE is doing and it's also
a bit rude. 

(FWIW, there's a bunch of issues with KDE doing this that will result in
interoperability issues and headaches going forward etc. See the upstream ml
archive for discussion. At the very least KDE should be using it's own directory
and not pretend what it's doing is a D-Bus thing.)

By having the dbus owning that directory it would be condoning this behavior.
That's just not going to happen. Sorry. Please take the problem upstream.
Comment 5 Rex Dieter 2007-10-16 12:55:34 EDT
fair enough, will do.
Comment 6 Kevin Kofler 2007-10-16 13:15:56 EDT
FWIW, OpenSUSE is now installing the directory in their dbus-1 package: 
http://lists.opensuse.org/archive/opensuse-commit/2007-10/msg00019.html
Comment 7 David Zeuthen 2007-10-16 14:01:00 EDT
FWIW, I've taken this to the D-Bus list

 http://lists.freedesktop.org/archives/dbus/2007-October/008773.html

Hopefully it will revive the discussion on how to properly handle this in a DE
independent way. Thanks.
Comment 8 Kevin Kofler 2007-10-16 14:22:31 EDT
You should make it clear that by "not agreed to", you mean "got no answer" (see 
http://lists.freedesktop.org/archives/dbus/2007-March/007434.html , the only 
reply was about another part of Thiago's mail), not "was explicitly 
disapproved", so I can understand the KDE people to have taken that as approval 
(also because in KDE world, no objections usually imply approval).
Comment 9 David Zeuthen 2007-10-16 14:29:14 EDT
(In reply to comment #8)
> You should make it clear that by "not agreed to", you mean "got no answer" (see 
> http://lists.freedesktop.org/archives/dbus/2007-March/007434.html , the only 
> reply was about another part of Thiago's mail), not "was explicitly 
> disapproved", so I can understand the KDE people to have taken that as approval 

Please take a minute to try and understand the issues before you start turning
this into politics. If you read the very link above you will see that a KDE4
package is providing the file

 org.freedesktop.ScreenSaver.xml

in the disputed directory. Clearly, if gnome-screensaver just decided to
implement standards, like this, without caring about getting things upstream you
would have a file conflict because that service also implements that interface.

> (also because in KDE world, no objections usually imply approval).

FWIW, I really hope you are not speaking for KDE with such a statement. Again,
don't bother posting to this bug anymore; it's closed. Participate upstream
instead. And feel free to reopen the bug once the issue is settled upstream. Thanks.
Comment 10 Rex Dieter 2009-05-06 10:04:51 EDT
Just noticed dbus does own this now, for better or worse,

* Wed Jul 23 2008 Matthias Clasen <mclasen@redhat.com> - 1.2.1-7
- Own /usr/share/dbus-1/interfaces

I'll cleanup the multiple ownership now (in the kde-stack anyway).

Note You need to log in before you can comment on or make changes to this bug.