Bug 334791 - Latest update makes screen flicker horribly
Latest update makes screen flicker horribly
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-16 12:56 EDT by Orion Poplawski
Modified: 2008-04-03 18:07 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-03 18:07:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.conf (870 bytes, application/octet-stream)
2007-10-16 12:56 EDT, Orion Poplawski
no flags Details
X log - flicker (82.50 KB, text/plain)
2007-10-16 12:57 EDT, Orion Poplawski
no flags Details
X log - old/good (59.96 KB, application/octet-stream)
2007-10-16 12:57 EDT, Orion Poplawski
no flags Details
x log - no Modes line (52.57 KB, application/octet-stream)
2007-10-24 17:05 EDT, Orion Poplawski
no flags Details

  None (edit)
Description Orion Poplawski 2007-10-16 12:56:20 EDT
Description of problem:

Rebooted after the latest round of xorg updates and now the CRT connected to my
docked (and lid-closed) laptop is flickering horribly - looks like 60Hz refresh.

Oct 16 09:43:01 Updated: xorg-x11-proto-devel - 7.3-3.fc8.noarch
Oct 16 09:50:15 Updated: xorg-x11-xinit - 1.0.7-2.fc8.i386
Oct 16 10:02:58 Updated: xorg-x11-server-Xorg - 1.3.0.0-30.fc8.i386
Oct 16 10:04:22 Updated: xorg-x11-drv-keyboard - 1.2.2-2.fc8.i386
Oct 16 10:04:28 Updated: xorg-x11-drv-i810 - 2.1.1-5.fc8.i386
Oct 16 10:07:12 Updated: xorg-x11-drv-vmmouse - 12.4.3-1.fc8.i386
Oct 16 10:07:15 Updated: xorg-x11-drv-vmware - 10.15.2-1.fc8.i386
Oct 16 10:07:16 Updated: xorg-x11-drv-ati - 6.7.195-3.fc8.i386
Oct 16 10:07:17 Updated: xorg-x11-drv-nouveau - 2.1.5-2.fc8.i386
Oct 16 10:07:18 Updated: xorg-x11-drv-nv - 2.1.5-2.fc8.i386
Oct 16 10:12:40 Installed: xorg-x11-drv-avivo - 0.0.1-6.fc8.i386
Oct 16 10:15:55 Updated: xorg-x11-drivers - 7.2-9.fc8.i386
Comment 1 Orion Poplawski 2007-10-16 12:56:20 EDT
Created attachment 229021 [details]
xorg.conf
Comment 2 Orion Poplawski 2007-10-16 12:57:05 EDT
Created attachment 229031 [details]
X log - flicker
Comment 3 Orion Poplawski 2007-10-16 12:57:41 EDT
Created attachment 229041 [details]
X log - old/good
Comment 4 Orion Poplawski 2007-10-24 17:05:52 EDT
Created attachment 236661 [details]
x log - no Modes line

If I remove the Modes "1600x1024" line now, it attempts to drive the CRT at
1024x768 with 117.8kHz/146Hz which is out of range.
Comment 5 Orion Poplawski 2007-10-24 17:42:44 EDT
Built new radeon driver from latest git, still the same.  Monitor OSD reports
rate as 73.9kHz/59Hz.

[root@cynosure ~]# xrandr
Screen 0: minimum 320 x 200, current 1600 x 1200, maximum 1600 x 1200
VGA-0 connected 1600x1200+0+0 (normal left inverted right x axis y axis) 352mm x
264mm
   1600x1200      85.0*+   75.0
   1024x768       85.0     75.1
   1280x1024      84.8     75.0
   1152x864       75.0
   800x600        84.9     75.0
   640x480        84.6     75.0     60.0
   720x400        70.1
LVDS disconnected (normal left inverted right x axis y axis)
S-video disconnected (normal left inverted right x axis y axis)

[root@cynosure ~]# xrandr --output VGA-0 --refresh 85
[root@cynosure ~]# xrandr --output VGA-0 --refresh 75

has no effect.
Comment 6 Orion Poplawski 2008-04-03 18:07:03 EDT
I no longer have this hardware and so can no longer test.

Note You need to log in before you can comment on or make changes to this bug.