Bug 334901 - Eclipse not initializing add-ons?
Eclipse not initializing add-ons?
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Andrew Overholt
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-16 13:40 EDT by Daryll
Modified: 2007-12-06 09:41 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-06 09:41:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Log File (4.82 KB, text/plain)
2007-10-16 14:33 EDT, Daryll
no flags Details

  None (edit)
Description Daryll 2007-10-16 13:40:05 EDT
It appears that eclipse-pde doesn't initialize properly. Other packages might
also be failing to initialize.

I believe that if the eclipse-pde is running correctly I should get a new
perspective under the window...open perspective...other. No new perspective appears.

If I click on the plug-in development link in the what's new page, nothing happens.

If I look at the rest of the welcome material...

None of the links in overview appear to do anything.

Under tutorials, clicking pretty much any of the links causes eclipse to crash. 

None of the links in samples appear to do anything.

Most of the links in what new don't appear to do anything. New Updates brings up
the updates window, eclipse communit makes the web browser load a page.

I started with a F8T3 system with the latest updates and without eclipse
installed. rpm -qa | grep eclipse only shows eclipse-ecj-3.3.0-27.fc8 which is
required by gcc.

I then did 'yum install eclipse-pde'. That pulled in the eclipse, the PDE, and
several other dependencies, so I now have the following packages:
tomcat5-jasper-eclipse-5.5.23-9jpp.4.fc8
eclipse-cvs-client-3.3.0-27.fc8
eclipse-pde-3.3.0-27.fc8
eclipse-pde-runtime-3.3.0-27.fc8
icu4j-eclipse-3.6.1-1jpp.3.fc8
eclipse-rcp-3.3.0-27.fc8
eclipse-ecj-3.3.0-27.fc8
eclipse-jdt-3.3.0-27.fc8
eclipse-platform-3.3.0-27.fc8

I do a 'rm -rf ~/.eclipse ~/workspace' to make sure there's nothing hiding in
either of those locations.

I'm not sure if it's relevant, but '/usr/sbin/alternatives --config java' is set
to /usr/lib/jvm/jre-1.7.0-icedtea/bin/java.

Now I fire up eclipse.
It shows me the Fedora Eclipse splash screen.
I enter ~/workspace
The splash shows various initialization steps
I enter the welcome page.

Now I see the behavior described above.
Comment 1 Andrew Overholt 2007-10-16 14:03:34 EDT
That's really odd.  I can't duplicate.  What architecture are you on?
Comment 2 Daryll 2007-10-16 14:07:43 EDT
i386. dual core. laptop.

Linux ninja 2.6.23-6.fc8 #1 SMP Thu Oct 11 14:54:16 EDT 2007 i686 i686 i386
GNU/Linux

The same behavior happens when I downloaded eclipse eudroa from eclipse.org and
installed the plugins using the software upgrades.
Comment 3 Andrew Overholt 2007-10-16 14:10:43 EDT
So it's an upstream bug?
Comment 4 Daryll 2007-10-16 14:16:47 EDT
Hard to believe it's really an upstream bug, if it works for you. 

I suspect some interaction of packages in the F8 distro.



Comment 5 Andrew Overholt 2007-10-16 14:27:43 EDT
Is there anything in ~/workspace/.metadata/.log?
Comment 6 Daryll 2007-10-16 14:33:02 EDT
Created attachment 229121 [details]
Log File
Comment 7 Andrew Overholt 2007-10-16 14:40:08 EDT
Nothing interesting in the .log.  Can you try with another JVM to see if it's an
IcedTea bug (unlikely, but I'd like to narrow it out)?

I was planning on moving this machine to rawhide at some point.  I'll do so now,
I guess :)
Comment 8 Daryll 2007-10-16 14:54:28 EDT
I tried 1.5-gcj and 1.6 from Sun. The log shows they both got used. The same
message about pde.build already being installed appears, but nothing else. So it
looks like no joy there.

I usually find test3 to be a relatively safe place to jump in, so welcome to the
pool. :)

Comment 9 Andrew Overholt 2007-10-18 09:30:28 EDT
I installed an i386 box from scratch with F8t3 and updated to rawhide.  I can't
duplicate your problem :(

If you have any other details that you think would help track this down, please
post them here.  Thanks.
Comment 10 Daryll 2007-10-18 10:35:46 EDT
I guess that's good for everyone else, bad for me. :)

This is a laptop that's been upgraded through FC6, F7, and F8 over the last year
and a half. I'm guessing there must be some remnant left behind.

I don't see any other weird behavior, so I'm not sure what else to check.

Thanks for the help!
Comment 11 Daryll 2007-10-18 12:21:30 EDT
Thanks for the help guys!

I used rpm to remove everything with jpp in the name, plus the java packages,
and anything that depended on those (like open office). Then I installed the
eclipse and openoffice packages again.

Now everything fires up correctly. I'm not sure really caused the problems, but
a big hammer seems to have fixed it.
Comment 12 Andrew Overholt 2007-10-18 13:05:58 EDT
I'm sorry it took such a heavy solution to fix :(  But I'm glad you're back up
and running.  Shall we close this bug?

Note You need to log in before you can comment on or make changes to this bug.