Bug 335011 - Move libpulsecore.so* to /usr/lib(64)/pulseaudio/ to prevent being considered for multilib
Move libpulsecore.so* to /usr/lib(64)/pulseaudio/ to prevent being considered...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F8Blocker
  Show dependency treegraph
 
Reported: 2007-10-16 14:25 EDT by Jesse Keating
Modified: 2013-01-09 21:41 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-17 17:26:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jesse Keating 2007-10-16 14:25:23 EDT
In order to satisfy runtime multilib setups we tag anything that drops a library
file in (/usr/)lib(64)/ as being multilib.  pulseaudio currently drops a library
in /usr/lib64/libpulse.so.0.3.0 for example.  If this library (which I'm told is
purely for internal pulseaudio use) is moved to libdir/pulseaudio/ it would
avoid being tagged for multilib and we would resolve the current conflicts we have.
Comment 1 Lennart Poettering 2007-10-17 17:26:21 EDT
As discussed on IRC, moving libpulsecore to some private directory doesn't
really work because the library is then no longer found by the dynamic loader.
This could be worked around by -rpath or /etc/ld.so.conf/, both of which are not
allowed on other distributions, and I'd be very unhappy if I'd have to ship PA
with different build systems for Fedora and the rest.

Instead I now split off libpulsecore into its own package pulseaudio-core-libs,
which should fix the problem, too.

0.16.svn20071017

Note You need to log in before you can comment on or make changes to this bug.