This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 335031 - NFS without rpcbind gets stuck forever
NFS without rpcbind gets stuck forever
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: nfs-utils (Show other bugs)
8
All Linux
high Severity high
: ---
: ---
Assigned To: Steve Dickson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-16 14:29 EDT by Warren Togami
Modified: 2008-04-25 11:23 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-25 11:23:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Warren Togami 2007-10-16 14:29:36 EDT
If rpcbind is not running for some reason, and service nfs starts, it gets stuck
forever.

Starting NFS services:                                     [  OK  ]
Starting NFS quotas: Cannot register service: RPC: Unable to receive; errno =
Connection refused
rpc.rquotad: unable to register (RQUOTAPROG, RQUOTAVERS, udp).
                                                           [FAILED]
Starting NFS daemon: 

This is especially bad because it makes boot be stuck forever.  It should just
fail instead of getting stuck.
Comment 1 Terje Røsten 2007-10-19 16:17:07 EDT
> If rpcbind is not running for some reason, and service nfs starts, 
> it gets stuck forever.

I guess this is in fact is #337451

Could you please check warren?
Comment 2 Warren Togami 2007-10-19 16:22:50 EDT
No, that was only one way to expose this bug.  This is a distinctly different bug.
Comment 3 Warren Togami 2007-10-19 17:02:47 EDT
It is getting stuck at nfssvc.c:96 during the write() call.

(gdb) bt
#0  0x00002aaaaaf90e80 in __write_nocancel () from /lib64/libc.so.6
#1  0x00002aaaaaaacb18 in nfssvc (port=<value optimized out>, nrservs=8,
versbits=4294967295, protobits=4294967295, haddr=0x2aaaaaccb560 "0.0.0.0") at
nfssvc.c:96
#2  0x00002aaaaaaac53d in main (argc=2, argv=<value optimized out>) at nfsd.c:161

94        if (udpfd >= 0) {
95                snprintf(buf, BUFSIZ,"%d\n", udpfd);
96                if (write(fd, buf, strlen(buf)) != strlen(buf)) {

Comment 4 Steve Dickson 2007-10-22 17:19:31 EDT
How long is "forever" :-)

In my testing I have to wait about 5 to 7 mins but 
eventually I get a timeout after a ton of 

    rpcbind: server localhost not responding, timed out
    RPC: failed to contact local rpcbind server (errno 5).
in /var/log/messages. Are you seeing these log entries? 
Comment 5 Bug Zapper 2008-04-04 10:07:48 EDT
Based on the date this bug was created, it appears to have been reported
during the development of Fedora 8. In order to refocus our efforts as
a project we are changing the version of this bug to '8'.

If this bug still exists in rawhide, please change the version back to
rawhide.
(If you're unable to change the bug's version, add a comment to the bug
and someone will change it for you.)

Thanks for your help and we apologize for the interruption.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.

Note You need to log in before you can comment on or make changes to this bug.