Bug 33513 - Install via NFS on 486 fails
Install via NFS on 486 fails
Status: CLOSED CURRENTRELEASE
Product: Red Hat Raw Hide
Classification: Retired
Component: installer (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-27 18:22 EST by Dennis Lundkvist
Modified: 2007-04-18 12:32 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-16 21:12:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dennis Lundkvist 2001-03-27 18:22:14 EST
Trying to install on my 486 with bootnet.img using NFS,
I get passed DHCP and NFS names and then the last thing I see is:
"Running anaconda - please wait"
then I get:

install exited abnormally -- received signal 11
sending termination signals...done
disabling swap...
unmounting filesystems...
/mnt/runtime
/mnt/source umount failed (16)
/dev/pts
/proc
you may safely reboot your system

The previous version of rawhide "nearly" installed on this machine 
(packages got installed, but the installer bugged out at the very end, 
which is also why I'm trying this slightly newer version).

Maybe an anaconda issue?
Comment 1 Bill Nottingham 2001-03-27 18:34:31 EST
Does it have a PS/2 port?

How much memory does it have?
Comment 2 Dennis Lundkvist 2001-03-28 15:43:40 EST
Machine config:
Passive backplane mobo (ISA only)
AMI BIOS 080893
486 66MegaHurt, have also tried with a Pentium Overdrive to no avail...
32MB mem
1GB IDE HD
3Com EtherLink3 (3c509)
CirrusLogic GD5424 1MB?
PS/2 keyboard
Serial mouse

Comment 3 Bill Nottingham 2001-03-28 15:46:09 EST
What's the first message *before* the segfaut?
Comment 4 Dennis Lundkvist 2001-03-29 12:59:46 EST
Hmmm,
you mean between "Running anaconda" and "exited abbynormal"?
didn't see anything... does a clear screen just when the sig11 hits.
Got any debug flags for the installer so I can see what's really going on?
Comment 5 Brent Fox 2001-04-03 12:01:22 EDT
Are you trying to run the installer in GUI or text mode?
Comment 6 Dennis Lundkvist 2001-04-03 19:46:40 EDT
installer run in "text" mode...
Comment 7 Brent Fox 2001-04-05 11:33:59 EDT
Did you try Wolverine at any point?  As you know, Rawhide is a test bed and as
such, it may be less than stable.  Sounds like this could be a kernel or a
hardware issue, but that's just a guess.  
Sorry, there are no super secret debug flags for anaconda.  Most of the debug
messages are logged on VC3 and VC4.  So try this...as soon as you hit OK on the
screen where you specify the NFS server, hit Alt-F3 and see if any messages
appear out of the ordinary.  Try Alt-F4 too.  The problem here is that once you
get the sig 11, you may not be able to go back and forth between VC's anymore,
so you may have to try this more than once to see the messages on both VC3 and
VC4.  Do you see any error messages?
Comment 8 Dennis Lundkvist 2001-04-07 09:56:38 EDT
Checked VC3 and VC4, last thing that shows up:
VC3: * looking for USB mouse
VC4: <6>raid5 personality registered as nr 4

I presume that the USB mouse load comes after the raid... and there is no USB 
in this PC...

History:
First I tried RH7.0 which didn't work, so I tried Debian 2.2 to check if the PC 
would run Linux at all and it installed flawlessly, but being a RedHat 
afficianado I wasn't giving up so easily. So I moved on to Wolverine, which has 
a known kernel bug that broke 486 boot.
So then I tried RawHide (the previous version) which nearly made it to the end 
of install (really close, past package installation etc) but the next day there 
was a new release of RawHide so I downloaded that and here I am...
Comment 9 Brent Fox 2001-04-10 20:58:32 EDT
Now I am confused.  We know that Red Hat 7 works with 486s...and we've tested
our current internal builds too.  Normally I would think this is a hardware
problem, but since Debian works, I guess that's not it.  So do the newer trees
fail in the same place?  Has there been any improvement at all?
Comment 10 Bill Nottingham 2001-04-10 21:06:50 EDT
Newer rawhide trees would not make any difference. The installer in rawhide hasn't
been updated in a few weeks.
Comment 11 Dennis Lundkvist 2001-04-16 21:03:04 EDT
Downloaded new RawHide thursday last, installation now passes without errors.
Thanx anyway guys...
Comment 12 Bill Nottingham 2001-04-16 21:08:29 EDT
Oops, yeah, I was on crack. New rawhide wouldn't make a difference because
the installer code is the same, but it *would* make a difference because
the boot kernel the installer is running is different. So it's apparently
a fixed kernel bug. :)
Comment 13 Bill Nottingham 2001-04-16 21:10:14 EDT
Marking as 'fixed in 7.1'.
Comment 14 Bill Nottingham 2001-04-16 21:12:38 EDT
(hm, or I suppose it could have been the kudzu mouse probe bug, but that
shouldn't have segfaulted, even with the previously buggy code, as long
as there was a ps/2 port on the machine.)

Note You need to log in before you can comment on or make changes to this bug.