Bug 335391 - tachyon is missing 'good' alpha support
tachyon is missing 'good' alpha support
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: tachyon (Show other bugs)
rawhide
alpha Linux
low Severity low
: ---
: ---
Assigned To: Dominik 'Rathann' Mierzejewski
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-16 17:34 EDT by Oliver Falk
Modified: 2008-01-02 20:35 EST (History)
0 users

See Also:
Fixed In Version: 0.98-0.5.20070319.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-02 20:35:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Update patch that add's #ifndef __alpha__ (2.85 KB, patch)
2007-12-17 06:17 EST, Oliver Falk
no flags Details | Diff

  None (edit)
Description Oliver Falk 2007-10-16 17:34:06 EDT
I see target linux-alpha, but no linux-alpha-thr or linux-alpha-thr-ogl. It also
seems linux-alpha-lam and linux-alpha-lam-ogl is missing.

Can you please check this; Eventually ask upstream!? I can provide testbuilds
and/or account to the alpha koji buildsys if needed!
Comment 1 Dominik 'Rathann' Mierzejewski 2007-10-23 19:23:44 EDT
It's trivial to fix. I'll take care of this sometime soon and I'll send an
updated patch to upstream after we've tested it.
Comment 2 Oliver Falk 2007-10-24 03:04:19 EDT
Great! Thx!
Comment 3 Oliver Falk 2007-12-03 03:50:26 EST
any chance to get this done soon?
Comment 4 Dominik 'Rathann' Mierzejewski 2007-12-03 18:02:44 EST
Yes, almost done. What does rpm --eval %{_target_cpu} show on Alpha?
Comment 5 Oliver Falk 2007-12-04 06:42:48 EST
[root@gosa ~]# rpm --eval %{_target_cpu}
alpha
Comment 6 Dominik 'Rathann' Mierzejewski 2007-12-05 19:44:30 EST
This should do it then. cvs up ;)
Please close when you've tested it.
Comment 7 Oliver Falk 2007-12-06 18:08:16 EST
http://buildsys.zero42.at/koji/getfile?taskID=73766&name=build.log

There's still a problem. Some -m64 made it into compilation and alpha gcc
doesn't understand that option (well, it better should ignore it, I know,
but...) :-)
Comment 8 Dominik 'Rathann' Mierzejewski 2007-12-07 12:00:21 EST
...
mpicc -Wall -O2 -I/usr/lib/lam/h -DLinux -DMPI -DUSEJPEG -DUSEPNG   
-I/usr/include/libpng12    -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2
-fexceptions --param=ssp-buffer-size=4 -mieee -c ../src/api.c -o
../compile/linux-alpha-lam/libtachyon/api.o
cc1: error: unrecognized command line option "-m64"
mpicc: No such file or directory
...

This is a mystery. There's no "-m64" in the command line, so my guess is that
mpicc (lam) is adding that on its own. Having no working alpha Linux boxes, I
can't help here.
Comment 9 Oliver Falk 2007-12-08 18:27:15 EST
Well. lam isn't very alpha ready, so I do the reassign. :-)

Why not ready. Because of that:
[oliver@gosa alpha]$ rpm -qpl lam-devel-7.1.2-10.fc8.alpha.rpm |grep conf
/usr/include/lam/64/lam_config.h
/usr/include/lam/lam_config_bottom.h
/usr/lib/pkgconfig/lam.pc


If some program (like tachyon) request #include <lam_config.h>, how should gcc
pick that up? However, the -m64 that might come from lam as well, needs fixing also.

Can you please have a look? Thx.
Comment 10 Dominik 'Rathann' Mierzejewski 2007-12-13 15:52:02 EST
(In reply to comment #9)
> Well. lam isn't very alpha ready, so I do the reassign. :-)

Well I don't know about that...

> Why not ready. Because of that:
> [oliver@gosa alpha]$ rpm -qpl lam-devel-7.1.2-10.fc8.alpha.rpm |grep conf
> /usr/include/lam/64/lam_config.h
> /usr/include/lam/lam_config_bottom.h
> /usr/lib/pkgconfig/lam.pc
> 
> 
> If some program (like tachyon) request #include <lam_config.h>, how should gcc
> pick that up? However, the -m64 that might come from lam as well, needs fixing
also.
> 
> Can you please have a look? Thx.

The answer is to use pkg-config:
$ pkg-config --cflags lam
-I/usr/include/lam -I/usr/include/lam/64  

And I think there are more problems in tachyon, so I'll reassign it back.
Comment 11 Dominik 'Rathann' Mierzejewski 2007-12-13 17:03:21 EST
OK, try 0.98-0.5 build from devel.
Comment 12 Oliver Falk 2007-12-17 04:43:08 EST
Well. I think I've found the buggy function from lam:
./lam-7.1.2-rh1/tools/wrappers/wrap.cc:
-> lam_wrap_build_cflags

does the following:

cflags.push_back("-m" + mode);

And exactly this - I believe - produces the -m64; I think we should put this
into some #ifdef __alpha__.
Comment 13 Oliver Falk 2007-12-17 04:44:17 EST
Ah. It's all in this patch: lam-7.1.2-archinc.patch
Comment 14 Oliver Falk 2007-12-17 06:17:45 EST
Created attachment 289763 [details]
Update patch that add's #ifndef __alpha__

Oh yes. The #ifndefs made it!
Comment 15 Oliver Falk 2007-12-17 06:18:17 EST
Patch is - of course - for lam!
Comment 16 Dominik 'Rathann' Mierzejewski 2007-12-17 06:49:48 EST
Great. I think we should let the lam maintainer know about it, then. Perhaps in
a new bug report. May I close this one as fixed?
Comment 17 Oliver Falk 2007-12-17 06:54:04 EST
Yes, please move the changes from rawhide to f8 and close this bug via bodhi
afterwards!
Comment 18 Fedora Update System 2007-12-20 15:14:37 EST
tachyon-0.98-0.5.20070319.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update tachyon'
Comment 19 Fedora Update System 2008-01-02 20:35:01 EST
tachyon-0.98-0.5.20070319.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.