Bug 335421 - 'Automatically insert smiley images' fails
'Automatically insert smiley images' fails
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-16 18:13 EDT by Tim Waugh
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-31 14:55:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 431606 None None None Never

  None (edit)
Description Tim Waugh 2007-10-16 18:13:01 EDT
Description of problem:
The 'Automatically insert smiley images' option fails in F-7 and in rawhide, but
worked in FC-6.

Version-Release number of selected component (if applicable):
evolution-2.10.3-4.fc7
gtkhtml3-3.14.3-1.fc7

How reproducible:
100%

Steps to Reproduce:
1.Edit->Preferences, Composer Preferences
2.Check the 'Format messages as HTML' checkbox
3.Check the 'Automatically insert smiley images' checkbox
4.Close the dialog and click 'New->Mail Message'
5.In the message body type ':-)'

Actual results:
The smiley becomes a broken image.

Expected results:
A smiley face is shown.

Additional info:
Worked in FC-6:
evolution-2.8.3-2.fc6
gtkhtml3-3.12.3-1.fc6

Here is the failure:
[pid 27215] open("/usr/share/gtkhtml-3.14/icons/smiley-3.png", O_RDONLY) = -1 EN
OENT (No such file or directory)

Looks like these icons are now provided as stock GTK+ icons, e.g.
/usr/share/icons/gnome/16x16/stock/emoticons/stock_smiley-3.png
Comment 1 Matthew Barnes 2007-10-21 08:23:57 EDT
Also broken in F8.
Comment 2 Matthew Barnes 2007-10-31 14:55:18 EDT
Moving this upstream.  I have a patch for the problem.

http://bugzilla.gnome.org/show_bug.cgi?id=431606

Note You need to log in before you can comment on or make changes to this bug.