Bug 335451 - 'Save All' for attachments fails
'Save All' for attachments fails
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
7
All Linux
low Severity high
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-16 18:18 EDT by Tim Waugh
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-22 06:43:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 494425 None None None Never

  None (edit)
Description Tim Waugh 2007-10-16 18:18:08 EDT
Description of problem:
When several attachments are included in an email, the 'Save All' function is
very useful.  However, if any of the attachment filenames are the same as each
other, not all of the attachments will be saved, i.e. the filenames are trusted
to be unique.

Version-Release number of selected component (if applicable):
evolution-2.10.3-4.fc7

How reproducible:
100%

Steps to Reproduce:
1.Send an email and attach two different images both named 'image.jpg'
2.Using evolution to read the email, click 'Save All' at the top of the message.
  
Actual results:
Only one 'image.jpg' file is saved.

Expected results:
Some unique extension should be added to the end of the filename, in the same
way as when nautilus pastes a file into a directory in which a like-named file
already exists.

Setting severity to high because this can result in unintentional data loss with
no warning.
Comment 1 Milan Crha 2007-11-22 06:43:17 EST
Moving this upstream to existing bug [1], we will track problem there.

[1] http://bugzilla.gnome.org/show_bug.cgi?id=494425

Note You need to log in before you can comment on or make changes to this bug.