This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 33568 - Oracle Installer problems with latest beta
Oracle Installer problems with latest beta
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: glibc (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-27 22:30 EST by David Lawrence
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-28 14:40:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description David Lawrence 2001-03-27 22:30:54 EST
I am getting errors when trying to install Oracle 8.1.6 for Linux and 8.1.7
for Linux on one of our latest builds. Everything seems to go well until it
starts to do the long file copy process. During the middle of the copy, an
error dialog box pops up saying:

Error in invoking target install of makefile
/u01/app/oracle/product/8.1.6/sqlplus/lib/ins_sqlplus.mk

You have the option of 'Retry', 'Ignore' or 'Cancel'. Obviously if I retry
it just comes back with the same so I ignore and I anther one stating:

Error in invoking target install of makefile
/u01/app/oracle/product/8.1.6/network/lib/ins_net_client.mk

Six or seven  more of these similar dialogs pop before the copy process is
over all relating to make file failing for specific oracle libraries.

I have been able to install 8.1.6 on 6.2 in the past but have not been able
to successfully install since 7.0 due to Java/Glibc related problems.  One
point is that the install did not fail like this in 7.0. It actually was
able to get all the way through the file copy and make process without
error.
Comment 1 Jakub Jelinek 2001-03-28 11:29:40 EST
Have you followed the procedure I posted
(ie.:
1) Make sure you have the following packages installed
compat-egcs-6.2-1.1.2.12
compat-glibc-6.2-2.1.3.2
compat-libs-6.2-3
binutils-2.10.91.0.2-3
glibc-2.2.2-9
glibc-common-2.2.2-9
glibc-devel-2.2.2-9
some recent gcc and cpp (2.96-79 is good)
2)
export LD_ASSUME_KERNEL=2.2.5 # This is in case Oracle installed runs broken JDK
export LDEMULATION=elf_i386_glibc21 # This is so that when genclntsh runs
                                    # ld, it first looks at /usr/i386-glibc21-linux/lib
                                    # for libraries
export GCC_EXEC_PREFIX=/usr/i386-glibc21-linux/lib/gcc-lib/
                                    # This is so that the gcc driver uses
                                    # the compatibility compiler
run the Oracle installer
)?
Comment 2 David Lawrence 2001-03-28 14:40:20 EST
I first tried it from an end-user perspective and ran it unchanged on a 7.1 beta
box. This is where I encountered the above errors. I then went back and add the
changes you suggested. I was actually able to finish the install normally and
even create a sample database using the Oracle installer. The database could be
started and shutdown normally with the admin commands to do so. I am starting
from scatch and then try to install the new 8.1.7 for Linux with the changes you
recommended. More on that.
Comment 3 David Lawrence 2001-03-28 17:21:11 EST
8.1.7 also seems to work well with changes. Thank you for the advice. This
really needs to be in a knowledge base somewhere if not already.

Note You need to log in before you can comment on or make changes to this bug.