Bug 33571 - "snmpd status" always returns 0 in ucd-snmp-4.2-9
"snmpd status" always returns 0 in ucd-snmp-4.2-9
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: ucd-snmp (Show other bugs)
7.1
i386 Linux
high Severity high
: ---
: ---
Assigned To: Crutcher Dunnavant
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-27 23:22 EST by Matt Domsch
Modified: 2005-10-31 17:00 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-27 23:40:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt Domsch 2001-03-27 23:22:30 EST
When we do "snmpd status", it always return 0 inspite of snmpd not 
running. This is a bug in /etc/rc.d/init.d/snmpd startup script. In the 
script, "RETVAL" environment variable is not properly set for status.
Basically, status() returns 3 in this case, but then 0 is returned from 
the script.  RETVAL needs to get set after calling status().

Because of this, dellomsa cannot check the correct status of snmpd and it 
will not start snmpd if it not already started.

Patch to /etc/rc.d/init.d/snmpd is here.  As this is a trivial yet 
functionally necessary change, Dell would like to see this addressed.

--- snmpd.orig  Tue Mar 27 21:44:11 2001
+++ snmpd       Tue Mar 27 22:18:43 2001
@@ -68,6 +68,7 @@
        ;;
   status)
         status snmpd
+       RETVAL=$?
         ;;
   *)
        echo $"Usage: $0 {start|stop|status|restart|condrestart|reload}"
Comment 1 Matt Wilson 2001-03-27 23:40:46 EST
ucd-snmp-4.2-10

Note You need to log in before you can comment on or make changes to this bug.