Bug 33572 - /kerberosIV/des.h incompatible with OpenSSL des.h
Summary: /kerberosIV/des.h incompatible with OpenSSL des.h
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: krb5 (Show other bugs)
(Show other bugs)
Version: 6.2
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-03-28 04:46 UTC by Damien Miller
Modified: 2007-04-18 16:32 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-24 00:21:00 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Damien Miller 2001-03-28 04:46:47 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.2.17-14 i686; en-US; 0.8)
Gecko/20010216


/usr/kerberos/include/kerberosIV/des.h defines many of the same symbols and
functions as /usr/include/openssl/des.h leading to compilation failure when
building software that uses both.

Reproducible: Always
Steps to Reproduce:
1.Checkout OpenSSH CVS head (www.openssh.com/portable.html)
2.autorecon
3. LDFLAGS=-L/usr/kerberos/lib/ CPPFLAGS="-I/usr/kerberos/include/
-I/usr/kerberos/include/kerberosIV/" ./configure --prefix=/usr
--sysconfdir=/etc/ssh --with-tcp-wrappers --with-kerberos4
4. make

Actual Results:  /usr/kerberos/include/kerberosIV/des.h:116: conflicting
types for `bit_64'
/usr/include/openssl/des.h:260: previous declaration of `bit_64'
/usr/kerberos/include/kerberosIV/des.h:128: conflicting types for
`des_key_sched'

etc

OpenBSD have resolved these problems by modifying their KerberosIV libs to
link directly against the DES routines provided by OpenSSL

Comment 1 Nalin Dahyabhai 2001-03-30 05:04:44 UTC
Known issue, solvable in the case of OpenBSD because IIRC the libdes used
by KTH Kerberos 4 is derived from the same source as the one in OpenSSL's
libcrypto, which is not the case with the MIT distribution.

Comment 2 Nalin Dahyabhai 2004-08-24 00:21:00 UTC
The OpenSSL folks renamed the symbols in libcrypto in the 0.9.7
release, marking this as fixed in the current release.


Note You need to log in before you can comment on or make changes to this bug.