Bug 336031 - Found Audio Device but no sound
Found Audio Device but no sound
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-17 08:22 EDT by Mauricio Pretto
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-29 15:47:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
scsconfig logfile (54.51 KB, text/plain)
2007-10-17 08:22 EDT, Mauricio Pretto
no flags Details

  None (edit)
Description Mauricio Pretto 2007-10-17 08:22:17 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:

The sound seems to work perfect, the driver was found and everything else, but
there is no sound.

Steps to Reproduce:
1.
2.
3.
  
Actual results:
No sound

Expected results:
Sound :)

Additional info:
Attached goes the  scsconfig.log
Comment 1 Mauricio Pretto 2007-10-17 08:22:18 EDT
Created attachment 229811 [details]
scsconfig logfile
Comment 2 Chuck Ebbert 2007-10-17 12:32:26 EDT
From dmesg:

hda_codec: Unknown model for ALC268, trying auto-probe from BIOS...

You may need to run the 'alsaunmute' program on boot.

  alsaunmute 0

Also, there is a test kernel with ALSA 1.0.15 at:

  http://people.redhat.com/cebbert/kernels/F8/x86_64/

Comment 3 Mauricio Pretto 2007-10-17 12:42:57 EDT
the alsaunmute doesnt help
will try this kernel , should i give a feedback about the kernel here?
Comment 4 Mauricio Pretto 2007-10-17 13:43:35 EDT
This kernel works just fine, thanks
Comment 5 Mauricio Pretto 2007-10-17 16:40:58 EDT
now it looks like i got some problem with alsa

rhythmbox doesn't work got the following message:

(rhythmbox:5039): GStreamer-WARNING **: pad mpegaudioparse0:src returned caps
which are not a real subset of its template caps

gnome-sound-proprieties:

sound-properties-Message: Error running pipeline 'audiotestsrc wave=sine
freq=512 ! audioconvert ! audioresample ! gconfaudiosink': Internal GStreamer
error: state change failed.  Please file a bug at
http://bugzilla.gnome.org/enter_bug.cgi?product=GStreamer.
[gstswitchsink.c(155): gst_switch_commit_new_kid (): /pipeline0/gconfaudiosink0:
Failed to set state on new child.]
Comment 6 Mauricio Pretto 2007-10-17 16:59:14 EDT
Ok, switched to OSS in the sound-proprieties and everything its working.
Comment 7 Mauricio Pretto 2007-10-18 08:59:56 EDT
I removed the alsa-lib i386 and everything worked just fine, but need to install
the alsa-lib i386 again because of firefox i386 and no sound again.
Comment 8 Kyle Gonzales 2007-10-25 16:10:18 EDT
Laptop: HP DV9500T laptop (Intel Core2 Duo, Santa Rosa chipset)
Audio Chip: Intel HD Azalia chip (kernel module snd-hda-intel)

Standard F8T3 kernel does not enable sound.  However, the kernel at:

  http://people.redhat.com/cebbert/kernels/F8/x86_64/

fixes this issue.  Sounds works now.

Will this make it into F8 GA?
Comment 9 Mauricio Pretto 2007-10-25 16:18:37 EDT
im using the 2.6.24-rc1 and works fine dont even need a alsa patch
Hope F8 Final comes with 24 :)
Comment 10 Mauricio Pretto 2007-10-29 09:47:12 EDT
i think the 2.6.23.1-37.fc8 solves all my problems.
Comment 11 Chuck Ebbert 2007-10-29 15:47:06 EDT
Looks like this kernel will go into F8, it fixes way more problems than it causes.
Comment 12 Mauricio Pretto 2007-10-29 15:51:20 EDT
the microphone its not working, just sent a message at test-list with more infos

Note You need to log in before you can comment on or make changes to this bug.