Bug 3362 - Floppy drive functionality on Sparc Ultra 5 (PCI bus)
Floppy drive functionality on Sparc Ultra 5 (PCI bus)
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: mount (Show other bugs)
6.0
sparc Linux
medium Severity medium
: ---
: ---
Assigned To: David Miller
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-06-09 11:03 EDT by baileydl
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-08-13 19:19:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description baileydl 1999-06-09 11:03:17 EDT
Have done a self test on the floppy drive--OK.  On boot, the
floppy drive seems to be detected by the kernel--OK.

However, mounting or formatting disks fail.  The same
commands and disks work fine on the Intel boxes, but cause
I/O errors or complete hangs on the Ultra 5.
Comment 1 baileydl 1999-06-09 13:14:59 EDT
Same drive works fine in Solaris, formats, mounts, reads OK.

Used brand new floppy and performed df on Intel with results:

Filesystem	1k-blocks	Used	Available	Use%
/dev/fd0	7415699		666085	6365261		9%

However, df in Linux on Ultra 5 of same new floppy returns:

/dev/fd0	5375599		1037830	4059435		20%

dmesg from bootup reports:
FDC 0 is a National Semiconductor PC87306
Comment 2 David Miller 1999-08-02 04:16:59 EDT
I am working on this bug, I've known about it for some
time.  If things work out, the upcoming kernel erratas
will fix this problem.  It only happens on Ultra5/Ultra10
systems, other PCI and SBUS Sparcs should be OK about
floppies for the most part.
Comment 3 David Miller 1999-08-03 03:23:59 EDT
I've found and fixed this bug.  It will be fixed in the
upcoming kernel updates...

Note You need to log in before you can comment on or make changes to this bug.