Bug 336271 - Partition names for MPIO devices is inconsistent
Partition names for MPIO devices is inconsistent
Status: CLOSED DUPLICATE of bug 320101
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: device-mapper-multipath (Show other bugs)
4.5
All Linux
low Severity high
: ---
: ---
Assigned To: LVM and device-mapper development team
Corey Marthaler
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-17 11:14 EDT by Joe Sunday
Modified: 2010-01-11 21:31 EST (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-23 09:42:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joe Sunday 2007-10-17 11:14:03 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. Map two FCP luns through MPIO with partition tables. Map one to have the device name end in a 
number, and one to end in a letter
2. Observe the /dev/mpath and /dev/mapper entries for both

  
Actual results:
The partition tag varies depending on the last character of the alias or UUID. If the last character is 
numeric, the partition tag is 'p' + the partition number. If the last character is alphabetic, the partition 
tag is simply the partition number.

# ls -l /dev/mpath
lrwxrwxrwx  1 root root 8 Oct 16 10:50 360a98000433465714b6f447356536236 -> ../dm-12
lrwxrwxrwx  1 root root 8 Oct 16 10:50 360a98000433465714b6f447356536236p1 -> ../dm-18
lrwxrwxrwx  1 root root 8 Oct 16 10:50 360a9800056716c70474a447356796e6f -> ../dm-15
lrwxrwxrwx  1 root root 8 Oct 16 10:50 360a9800056716c70474a447356796e6f1 -> ../dm-19

Expected results:
The partition tag should be consistent without depending on context from the lun name itself.
Because you need a non-numeric separator for whole-disk devices that end in number, it should just 
always use 'pX' syntax and not have a special case.

Additional info:
This makes it hard to map the same partition number across luns, as might happen during a SAN lun 
clone operation. If the prior UUID and the cloned UUID differ, the partition tags will change as well and 
can not be derived from the base lun and partition alone.

With sdXY and hdXY devices, it is always possible to generate the new partition device from the old 
device and the new base device via string manipulation alone. Changing the suffix depending on the 
base device name in the multipath case breaks that assumption for no good reason.
Comment 1 Tom Coughlan 2007-10-23 09:42:56 EDT

*** This bug has been marked as a duplicate of 320101 ***

Note You need to log in before you can comment on or make changes to this bug.