This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 336291 - XendError: /usr/lib64/xen/bin/xc_save 4 2 0 0 0 failed
XendError: /usr/lib64/xen/bin/xc_save 4 2 0 0 0 failed
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xen (Show other bugs)
5.0
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Xen Maintainance List
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-17 11:33 EDT by Robert Scheck
Modified: 2009-12-14 16:25 EST (History)
1 user (show)

See Also:
Fixed In Version: 5.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-11 18:43:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Relevant parts from /var/log/xen/xend.log (10.80 KB, text/plain)
2007-10-17 11:39 EDT, Robert Scheck
no flags Details

  None (edit)
Description Robert Scheck 2007-10-17 11:33:24 EDT
Description of problem:
We've the problem, that when rebooting the Dom0 with "reboot", the DomUs are 
not shut down correctly, because of "XendError: /usr/lib64/xen/bin/xc_save 4 2 
0 0 0 failed". And this results in, that the machines are not brought up after 
the reboot.

Version-Release number of selected component (if applicable):
xen-3.0.3-25.0.4.el5

How reproducible:
Everytime, see above.

Actual results:
Unclean shutdown of DomU caused by a reboot at Dom0 results in no booting of 
DomU after the reboot (as in initial description).

Expected results:
Working stuff. Reboot of Dom0 cleanly shuts down the DomU and brings it also 
correctly back...

Additional info:
[2007-10-17 15:56:26 xend 4935] DEBUG (XendCheckpoint:83) [xc_save]: /usr/lib64/
xen/bin/xc_save 4 2 0 0 0
[2007-10-17 15:56:26 xend 4935] INFO (XendCheckpoint:239) Couldn't map 
p2m_frame_list_list (errno 14): 14
[2007-10-17 15:56:26 xend 4935] INFO (XendCheckpoint:239) Save exit rc=1
[2007-10-17 15:56:26 xend 4935] ERROR (XendCheckpoint:106) Save failed on 
domain central (2).
Traceback (most recent call last):
  File "/usr/lib64/python2.4/site-packages/xen/xend/XendCheckpoint.py", line 
100, in save
    forkHelper(cmd, fd, saveInputHandler, False)
  File "/usr/lib64/python2.4/site-packages/xen/xend/XendCheckpoint.py", line 
227, in forkHelper
    raise XendError("%s failed" % string.join(cmd))
XendError: /usr/lib64/xen/bin/xc_save 4 2 0 0 0 failed
[2007-10-17 15:56:26 xend 4935] DEBUG (image:458) hvm_shutdown fired, shutdown 
reason=halt
[2007-10-17 15:56:26 xend.XendDomainInfo 4935] INFO (XendDomainInfo:899) Domain 
has shutdown: name=central id=2 reason=halt.
[2007-10-17 15:56:26 xend.XendDomainInfo 4935] DEBUG (XendDomainInfo:1463) 
XendDomainInfo.destroy: domid=2
[2007-10-17 15:56:26 xend.XendDomainInfo 4935] DEBUG (XendDomainInfo:1471) 
XendDomainInfo.destroyDomain(2)
[2007-10-17 15:56:26 xend 4935] DEBUG (image:447) hvm shutdown watch 
unregistered
Comment 1 Robert Scheck 2007-10-17 11:39:17 EDT
Created attachment 229941 [details]
Relevant parts from /var/log/xen/xend.log

Please note, that this is a productive machine which I can't reboot just for
fun or for just another test to see whether it works. Of course I'm willing to
provide you any log details and further information you need, and I'll test an
(inofficial) update also, if there's a chance, that it could solve this issue.
Comment 2 Chris Lalancette 2007-10-17 13:24:20 EDT
Correct me if I'm wrong; I believe the domains you are talking about are fully
virtualized domains.  If that is the case, the reason things aren't working is
that fully virtualized save/restore doesn't work/isn't supported in RHEL 5.0. 
This should be addressed by 5.1, which does support fully virtualized save/restore.

Chris Lalancette
Comment 3 Robert Scheck 2007-10-17 13:55:23 EDT
Chris, do you mean there is no HVM support in RHEL 5.0 or is RHEL 5.0 just 
lacking the ability to save/restore HVM DomUs? Finally last of it would be
IMHO just a logic feature by first. And first of it is supported as per RHEL 
5.0 documentation.

But to answer your question: Yes, the machine is fully virtualized. Anyway
it would be strange to me to see SLES before RHEL regarding this. And wasn't 
RHEL 5.1 supposed to come up soon?
Comment 4 Chris Lalancette 2007-10-17 14:39:00 EDT
There is HVM support in 5.0; just not HVM save/restore.  5.1 is coming out
fairly soon, although I don't have an exact schedule I can hand out.

Chris Lalancette
Comment 5 Robert Scheck 2007-12-11 18:05:26 EST
Works with Red Hat Enterprise Linux 5.1 - closing now.
Comment 6 Robert Scheck 2007-12-11 18:07:09 EST
Can somebody please close this bug report? I'm unfortunately not allowed to do.
It's fixed at least in xen-3.0.3-41.el5.

Note You need to log in before you can comment on or make changes to this bug.